Arcen Forums

Other => Website Support => Topic started by: Cyborg on April 15, 2016, 10:59:59 PM

Title: Website really slow
Post by: Cyborg on April 15, 2016, 10:59:59 PM
It's taking me forever even to post a message. Not happening at other sites.
Title: Re: Website really slow
Post by: Dominus Arbitrationis on April 15, 2016, 11:25:22 PM
I am aware of the issue and am working to get it resolved. (Wow that sounds like the super canned response that you get from the big companies)
Title: Re: Website really slow
Post by: x4000 on April 16, 2016, 12:11:26 AM
Been bugging me today, too. I tried to fix it but failed. Quinn seems to have gotten it, though, now. :)
Title: Re: Website really slow
Post by: Dominus Arbitrationis on April 16, 2016, 12:13:24 AM
Let me know if you're still having issues with the site's speed though! :)
Title: Re: Website really slow
Post by: Cinth on April 16, 2016, 03:54:44 AM
I am aware of the issue and am working to get it resolved. (Wow that sounds like the super canned response that you get from the big companies)

That is the canned response (except it's we're aware).  Suggesting feigned ignorance of issues existence and denial it ever happens ( wait, that's canned too :/)
Title: Re: Website really slow
Post by: x4000 on April 16, 2016, 02:38:16 PM
You are now banned for discontent. Wait, that's not right either. ;)
Title: Re: Website really slow
Post by: chemical_art on April 16, 2016, 05:24:15 PM
I can confirm that the website is running slower, but it is improved compared to what it was before.
Title: Re: Website really slow
Post by: Cyborg on April 16, 2016, 07:15:28 PM
There are some speed variations. Currently running very slow.
Title: Re: Website really slow
Post by: Mánagarmr on April 16, 2016, 07:16:44 PM
Very...slow.
Title: Re: Website really slow
Post by: chemical_art on April 19, 2016, 02:51:42 PM
Posting is a chore since things are running really slowly.
Title: Re: Website really slow
Post by: x4000 on April 19, 2016, 03:15:01 PM
Y...e...s...  I... ag...r...ee...

I am not sure what is going on.
Title: Re: Website really slow
Post by: Draco18s on April 19, 2016, 03:28:02 PM
I suppose I could mention that I've had a few Cloud Flare "site is not responding" pages.  Only about four since this thread was started, but non-zero.
Title: Re: Website really slow
Post by: x4000 on April 20, 2016, 02:05:00 PM
As at least a temporary measure, I've doubled the size of the hard drive of the vm, and doubled the ram.  Doesn't seem to be helping much if at all, though. :/

I think maybe the databases are running slow for some reason, I'm not sure.  That's just the only thing I can figure.
Title: Re: Website really slow
Post by: x4000 on April 20, 2016, 03:13:11 PM
Well, I just can't win.  For now, the wiki is down... because reasons.  I'm really not sure.

this is the contents of the error log:

Code: [Select]
[Wed Apr 20 15:04:13 2016] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Apr 20 15:04:13 2016] [notice] Digest: generating secret for digest authentication ...
[Wed Apr 20 15:04:13 2016] [notice] Digest: done
[Wed Apr 20 15:04:13 2016] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.6.20 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips configured -- resuming normal operations
[Wed Apr 20 15:04:18 2016] [error] server reached MaxClients setting, consider raising the MaxClients setting

I think that last one is the culprit.  I checked our httpd.conf file, and found this for our settings:

Code: [Select]
<IfModule prefork.c>
StartServers       1
MinSpareServers    1
MaxSpareServers    5
ServerLimit       10
MaxClients        10
MaxRequestsPerChild  4000
</IfModule>

<IfModule worker.c>
StartServers       1
MaxClients        10
MinSpareThreads    1
MaxSpareThreads    4
ThreadsPerChild     25
MaxRequestsPerChild  0
</IfModule>

I did some googling, and that seemed super low.  So I switched over to this:

Code: [Select]
<IfModule prefork.c>
StartServers       1
MinSpareServers    5
MaxSpareServers    10
ServerLimit       256
MaxClients        256
MaxRequestsPerChild  10000
</IfModule>

<IfModule worker.c>
StartServers       3
ServerLimit       16
MaxClients        5000
MinSpareThreads    50
MaxSpareThreads    250
ThreadsPerChild     50
MaxRequestsPerChild  10000
</IfModule>

That seemed to work!  ...kinda.

Longer wiki pages were coming up without formatting, but they were at least coming up.  The forums were maybe a tiny bit speedier, I'm not sure.  Mantis and wordpress were still slow as molasses.  But, worse, I started getting these errors on mantis whenever clicking into a ticket:

Code: [Select]
APPLICATION ERROR #400
Database connection failed. Error received from database was #1040: Too many connections.

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

Previous non-fatal errors occurred. Page contents follow.

SYSTEM WARNING: 'mysql_connect(): Too many connections' in '/var/www/html/arcengames.com/mantisbt/library/adodb/drivers/adodb-mysql.inc.php' line 365

And occasionally I'd get these from wordpress:

Quote
Error establishing a database connection

Well, gee.

So I tried this as my first compromise:

Quote
<IfModule prefork.c>
StartServers       1
MinSpareServers    1
MaxSpareServers    10
MaxClients        256
MaxRequestsPerChild  4000
</IfModule>

<IfModule worker.c>
StartServers       1
MaxClients        256
MinSpareThreads    1
MaxSpareThreads    40
ThreadsPerChild     25
MaxRequestsPerChild  0
</IfModule>

That still avoided the MaxClients error, so hooray.  But... same errors on mantis and wordpress.  Still the wiki kinda-sorta working, but at least not giving me 522 and 524 errors anymore.

Grr.  Okay, so one more compromise, and we arrive at the settings we are currently on:

Code: [Select]
<IfModule prefork.c>
StartServers       1
MinSpareServers    1
MaxSpareServers    5
ServerLimit       10
MaxClients        256
MaxRequestsPerChild  4000
</IfModule>

<IfModule worker.c>
StartServers       1
MaxClients        256
MinSpareThreads    1
MaxSpareThreads    4
ThreadsPerChild     25
MaxRequestsPerChild  0
</IfModule>

Hooray, all the main services work properly again... except, oh wait, the wiki is back to not even giving partial pages.  And that max clients error is in our error log again.

Any ideas from anyone?  This is super frustrating, and I've wasted my whole morning on it at this point. >:(
Title: Re: Website really slow
Post by: x4000 on April 20, 2016, 03:16:16 PM
Incidentally, here are the references I was using:  http://httpd.apache.org/docs/2.2/mod/mpm_common.html

and http://httpd.apache.org/docs/2.2/mod/prefork.html
and http://httpd.apache.org/docs/2.2/mod/worker.html

Also this had some info: http://serverfault.com/questions/276478/apache-limiting-connections-per-vhost
And this was useful to me: http://stackoverflow.com/questions/12202021/where-is-my-httpd-conf-file-located-apache (/etc/httpd/conf/httpd.conf was correct)

And... yeah.
Title: Re: Website really slow
Post by: Blue on April 22, 2016, 10:32:25 AM
How about now?
Title: Re: Website really slow
Post by: x4000 on April 22, 2016, 10:34:02 AM
Woohoo, it works! :D
Title: Re: Website really slow
Post by: Cinth on April 22, 2016, 10:36:12 AM
This is playing out like a twisted Verizon commercial.
Title: Re: Website really slow
Post by: x4000 on April 22, 2016, 10:39:01 AM
...with the guy switching to google fiber or something in the middle of the commercial, then it works. ;D
Title: Re: Website really slow
Post by: Cinth on April 22, 2016, 10:41:45 AM
 :D
Title: Re: Website really slow
Post by: Draco18s on April 22, 2016, 10:57:46 AM
Oh man, Firefox had the wrong password saved.  Last time I reset it was 2012!
Title: Re: Website really slow
Post by: x4000 on April 22, 2016, 10:58:23 AM
Ha -- wow!