Author Topic: Stored forum login gets corrupted repeatedly  (Read 2324 times)

Offline Draco18s

  • Resident Velociraptor
  • Core Member Mark V
  • *****
  • Posts: 4,059
Re: Stored forum login gets corrupted repeatedly
« Reply #15 on: June 27, 2015, 11:54:27 PM »
Well, firefox has indeed been a piece of sh!t lately. Can anyone recommend a better browser? I hear good things about Chrome.

But I'm a firefox grognard and conservative scum anyways. My browser add-ons! I NEED them! But firefox is so overloaded with useless features, slow, prone to crashing, one huge memory leak...
Have you tried Pale Moon? Its firefox but without the strange new ui shenanigans, and a bunch of tweaks. Most of your FF should be able to convert over fine, the rest is probably replaced (or known about, at least) on this page.

+1 recommendation for Pale Moon here.

Offline Dominus Arbitrationis

  • Arcen Games Contractor
  • Administrator
  • Sr. Member Mark III
  • *****
  • Posts: 451
Re: Stored forum login gets corrupted repeatedly
« Reply #16 on: June 27, 2015, 11:57:49 PM »
Firefox is complaining about one (or more) images not being from a secure source. A bit of searching through the source reveals that the Steam icon is the likely culprit ( http://steamcommunity.com/favicon.ico ).

Thanks! That was one of the culprits, the other was the background image was cached in all of our caches (Arcen's server caches, not user's) and it didn't want to be invalidated no matter what happened to the image. So I had to purge the cache throughout the site. Not a huge deal, just a minor annoyance for everyone, what with the slightly longer load times and all.
Come help out at the Wiki!

Have ideas or bug reports for one of Arcen's games or any part of the site? Use  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games and site better!

Offline Shrugging Khan

  • Hero Member Mark III
  • *****
  • Posts: 1,216
  • Neinzul Y PzKpfw Tiger!
Re: Stored forum login gets corrupted repeatedly
« Reply #17 on: June 28, 2015, 04:15:28 AM »
Thanks for the Pale Moon hint; will try it and Chrome some time soon-ish  :)
The beatings shall continue
until morale improves!

Offline WingedKagouti

  • Jr. Member
  • **
  • Posts: 52
Re: Stored forum login gets corrupted repeatedly
« Reply #18 on: June 28, 2015, 07:32:41 AM »
Firefox is complaining about one (or more) images not being from a secure source. A bit of searching through the source reveals that the Steam icon is the likely culprit ( http://steamcommunity.com/favicon.ico ).

Thanks! That was one of the culprits, the other was the background image was cached in all of our caches (Arcen's server caches, not user's) and it didn't want to be invalidated no matter what happened to the image. So I had to purge the cache throughout the site. Not a huge deal, just a minor annoyance for everyone, what with the slightly longer load times and all.
Aklyon's avatar (and I expect every other avatar hosted on a non-secure server) also causes the issue.

Offline Dominus Arbitrationis

  • Arcen Games Contractor
  • Administrator
  • Sr. Member Mark III
  • *****
  • Posts: 451
Re: Stored forum login gets corrupted repeatedly
« Reply #19 on: June 28, 2015, 08:37:41 AM »
Aklyon's avatar (and I expect every other avatar hosted on a non-secure server) also causes the issue.

Unfortunately not much I can do about that, short of changing everyone's avatar. One easy way to fix it is protocol relative links (//arcengames.com). That may not work for the avatars though, I haven't tested it.
Come help out at the Wiki!

Have ideas or bug reports for one of Arcen's games or any part of the site? Use  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games and site better!

Offline WingedKagouti

  • Jr. Member
  • **
  • Posts: 52
Re: Stored forum login gets corrupted repeatedly
« Reply #20 on: June 28, 2015, 08:57:40 AM »
Aklyon's avatar (and I expect every other avatar hosted on a non-secure server) also causes the issue.

Unfortunately not much I can do about that, short of changing everyone's avatar. One easy way to fix it is protocol relative links (//arcengames.com). That may not work for the avatars though, I haven't tested it.
I don't expect you to fix this (saving Arcen's bandwidth this way is quite sensible), but just giving a heads up for people who might be confused as to why the issue can occur.

Offline nas1m

  • Master Member
  • *****
  • Posts: 1,254
Re: Stored forum login gets corrupted repeatedly
« Reply #21 on: June 29, 2015, 03:55:01 PM »
My original issue seems to be fixed.
Thanks :)!
Craving some more color and variety in your next Bionic run? Grab a boost and a couple of custom floors!