General Category > Tidalis

Is the adventure editor broken or do I just not get it?


For lack of a 'New Adventure' button, I started by copy/pasting the original's files - the game picked up on that and automatically labelled it with the new folder's name. Creating new levels is easy enough, and I currently have the first within the same folder structure as the existing story levels (ie. its own "Levels For ..." folder). Scenes I haven't touched yet, but I'm guessing just copy/paste/tweaking the existing xml files in the same folder will work. I also changed the icon image and deleted all the original nodes from the new adventure.

My problem is that whenever I go into Edit Adventure Details and select my new folder as the the adventure's level set, the editor keeps resetting back to the normal "Levels For Tidalis Main Story" after closing the menu (yes, I am clicking Save). So I'm unable to select my new level when I add a node.

Did I miss / mess a step, or should I just take this as a glitch in a sadly unused feature?

I just tried it, myself, with a brand new adventure (made a new folder, set the level directory in the editor, and hit save) and saw the same sort of behavior. I'm betting that's a bug that we never encountered because we only made the one adventure. That adventure's .dat file contains a field for the level directory: LevelSetFolder:Levels For Tidalis Main Story. When I created my new adventure, there was no such field, so I think that option in the editor simply doesn't save whatsoever. I tried manually setting that field in a text editor and that seemed to work, so give that a try and see if it works for you.

Okay, that works. Now I can get this adventure underway proper!


[0] Message Index

Go to full version