General Category > The Last Federation

How to update Linux version


Last Federation got update with a fix of missing special powers icons, however the update is not on GOG.

Arcen games have usually auto-updater, but it seems that it is disabled for linux version of Last Federation.

Is there any option left in order to update the game?

Hmm, sorry about this!  The updater on gog should work just fine, not sure what is happening there.

I believe that you are on version 3.003, correct?  If that's the case, then you can simply download these two files:

Unzip the 3004 one first, overwriting any files, then unzip the 3005 one next, again overwriting any files.  Both into your root game folder.

After that is done, you will have a DB subfolder of your root game folder.  Go into that, and there is a Managed subfolder with a Assembly-CSharp.dll file inside that.  Simply copy that Assembly-CSharp.dll file from there and overwrite the file of the same name in your gameroot/LastFederationLinux_Data/Managed/ folder.

That should be it.  Sorry for the hassle!

I've tried the game run in Wine, and the updater works there, there is an extra button for updating the game which is missing in the Linux version. I've tried to run the updater manually, but that does not seem working either.

Anyway, thank you for the patch files, these helped.

I'm glad I could help!

In Linux (or any OS), if the patch update button is not appearing in the game, then that means it was not able to talk to Amazon S3. The two likely causes are "check for updates" being explicitly off in he settings for the game; or a firewall or other OS permissions blocking the game from contacting internet servers. That connection for an update check is the only network connection it makes.

Incidentally, the separate updater executable is actually more of an unpacker. The game itself does the update checking and downloading, and then fires up the updater, which just unpacks everything and restarts the game. Since we didn't get to that point, it's definitely a network permissions issue. I had thought it was having trouble after starting the update process.

Glad the manual patch workaround worked, though!


[0] Message Index

Go to full version