Arcen Games

General Category => Starward Rogue => : Sounds August 06, 2016, 08:11:59 PM

: Game doesn't run on OSX after latest patch
: Sounds August 06, 2016, 08:11:59 PM
Thought I'd give it a try this morning, but it seems the latest patch has broken the OSX version. It does not start at all now.

Any idea what to look at now?

Thanks.
: Re: Game doesn't run on OSX after latest patch
: x4000 August 06, 2016, 08:24:40 PM
Yikes!  Sorry about that -- it should work now.  We're on a newer version of unity now, and apparently compiling via visual studio no longer is compatible across.  That's definitely a bummer for us.  Please let me know if it still gives you any trouble, though.  You can restart steam to have it force a quicker update.
: Re: Game doesn't run on OSX after latest patch
: Cinth August 06, 2016, 08:27:11 PM
compiling via visual studio no longer is compatible across

Ewwwwwwww!  :'(
: Re: Game doesn't run on OSX after latest patch
: x4000 August 06, 2016, 08:28:30 PM
compiling via visual studio no longer is compatible across

Ewwwwwwww!  :'(

Yeah, frustrating.  You can still do it for the windows builds, so it won't affect anything internally.  And it may even work for the linux builds.  And possibly by setting some specific compiler flags it will also work for OSX; it would need more investigation.  But this seems to be the issue, at any rate.
: Re: Game doesn't run on OSX after latest patch
: Cinth August 06, 2016, 08:31:57 PM
I think everyone internal uses windows builds.  I've not built for the other platforms (you've handle that) so I don't know.
: Re: Game doesn't run on OSX after latest patch
: x4000 August 06, 2016, 08:33:05 PM
ptarth uses OSX at least some, but I believe he builds for himself when he does.  Pablo is also on OSX, but doesn't need builds, heh.
: Re: Game doesn't run on OSX after latest patch
: Cinth August 06, 2016, 08:34:30 PM
Ok then, I've only ever built windows builds for internal use :p 

No one has complained about it yet :)
: Re: Game doesn't run on OSX after latest patch
: ptarth August 06, 2016, 09:21:51 PM
That's Pepisolo I believe. I'm firmly anti-Apple. I have been trying to get a ubuntu laptop up and running to do some of the coding for work reasons, but it has been a slow obnoxious slog of pain and misery. If anyone has a good Lunbuntu xml and unity editor suggestions I'd be interested. I've been trying to get Eclipse to parse the xml, but without much success.
: Re: Game doesn't run on OSX after latest patch
: x4000 August 06, 2016, 09:33:33 PM
Oh sorry, I thought it was you.  Man, I mix the two of you up by your username, and him and Cinth up by their actual names.  I'm on a roll, with the Ps and Cs.  Apparently I confuse Pepi with everyone now. ;)

And actually, come to think of it, I think it's jerith that is on osx.
: Re: Game doesn't run on OSX after latest patch
: Sounds August 07, 2016, 02:16:05 AM
Just to let you know I just checked it again - it is still the same issue. :(

: Re: Game doesn't run on OSX after latest patch
: Sounds August 07, 2016, 04:30:09 AM
That's Pepisolo I believe. I'm firmly anti-Apple. I have been trying to get a ubuntu laptop up and running to do some of the coding for work reasons, but it has been a slow obnoxious slog of pain and misery. If anyone has a good Lunbuntu xml and unity editor suggestions I'd be interested. I've been trying to get Eclipse to parse the xml, but without much success.
I use debian for my my main workstation and various VMs for other work/servers/services, which I find perfect for the type of work I do. I just use an iMac mainly as the head for these machines, and some games for when I've got some downtime. This is what I had hoped to do today with SR, but unfortunately SR failed to boot, so I ended up playing Rimworld instead.
: Re: Game doesn't run on OSX after latest patch
: x4000 August 07, 2016, 12:50:35 PM
Sorry about this!  It works fine on my Mac (Yosemite 10.10.5), so I'm not sure what the problem is here.  It might be something didn't download right.  I'd suggest deleting StarwardRogue.app in the game's install folder, and then doing a verify local file cache.

If that doesn't work, then if you can look in the RuntimeData folder under the game's install folder and pass over any error logs you find there, that would be appreciated.

Thanks!
Chris
: Re: Game doesn't run on OSX after latest patch
: Sounds August 07, 2016, 07:32:39 PM
Sorry about this!  It works fine on my Mac (Yosemite 10.10.5), so I'm not sure what the problem is here.  It might be something didn't download right.  I'd suggest deleting StarwardRogue.app in the game's install folder, and then doing a verify local file cache.

If that doesn't work, then if you can look in the RuntimeData folder under the game's install folder and pass over any error logs you find there, that would be appreciated.

Thanks!
Chris

Hi Chris,

My mac is on OS X El Capitan (10.11.5), and SR was working on this version a week or two ago.

I did as you suggested and still no luck. Looking in the RuntimeData folder shows no error logs. There is a "ArcenDebugLog.txt" there and from I can see, it doesn't show anything of value.

I'd try a full uninstall and see whether that fixes it.

Fingers crossed,

Sounds :)
: Re: Game doesn't run on OSX after latest patch
: x4000 August 07, 2016, 07:36:06 PM
The version of unity has been updated, so that may be the reason that there is some sort of issue for you; it may also have something to do with your drivers, if the game is trying to use opengl core rather than opengl 2 and having issues there.  I'm not positive.  It sounds like it is not getting very far thanks to the error log being mostly empty.  There may be something better at this location: ~/Library/Logs/Unity/Player.log
: Re: Game doesn't run on OSX after latest patch
: Sounds August 07, 2016, 07:53:44 PM
The version of unity has been updated, so that may be the reason that there is some sort of issue for you; it may also have something to do with your drivers, if the game is trying to use opengl core rather than opengl 2 and having issues there.  I'm not positive.  It sounds like it is not getting very far thanks to the error log being mostly empty.  There may be something better at this location: ~/Library/Logs/Unity/Player.log

No luck with the reinstall.

Here the default dump and the Player.log files.
: Re: Game doesn't run on OSX after latest patch
: x4000 August 07, 2016, 08:06:21 PM
Okay, so what seems to be happening is it is outright failing to create a graphics device.  Deep in the basic initialization code for the engine itself, this is happening: CreateGLGfxDevice() is giving a null reference exception.

Based on some googling, this seems to be the solution: http://steamcommunity.com/app/370940/discussions/2/364042703863250257/
: Re: Game doesn't run on OSX after latest patch
: Sounds August 07, 2016, 08:34:37 PM
Okay, so what seems to be happening is it is outright failing to create a graphics device.  Deep in the basic initialization code for the engine itself, this is happening: CreateGLGfxDevice() is giving a null reference exception.

Based on some googling, this seems to be the solution: http://steamcommunity.com/app/370940/discussions/2/364042703863250257/

Did the change that was mentioned and it had no effect.

However by changing from my default dual display to mirrored it worked (and reverting back to dual display it fails again). Yay the error/fix is repeatable! :D

I guess SR doesn't like dual monitor displays unless they're mirrored in fullscreen - I can live with that.

The only other thing I noticed now is that the initialisation of the front screen takes around 5-10 secs to show - I can live with that too. Just thought I'd mention it for completeness.

Thanks again for all your help,

Sounds.

: Re: Game doesn't run on OSX after latest patch
: x4000 August 07, 2016, 09:06:24 PM
Gah!  That's definitely annoying as to why it's causing an issue, for sure.  My main desktop has four monitors, but I only use one with my mac.  So that explains the difference.  Something about dual monitors on osx really causes lots of trouble with a lot of software for some reason.  Apparently if you switch to using HDMI as the setting instead of lightning that might help?  That might be what you tried in the other thread, I'm not sure -- there were a variety of solutions in there.
: Re: Game doesn't run on OSX after latest patch
: Sounds August 07, 2016, 09:35:42 PM
Gah!  That's definitely annoying as to why it's causing an issue, for sure.  My main desktop has four monitors, but I only use one with my mac.  So that explains the difference.  Something about dual monitors on osx really causes lots of trouble with a lot of software for some reason.  Apparently if you switch to using HDMI as the setting instead of lightning that might help?  That might be what you tried in the other thread, I'm not sure -- there were a variety of solutions in there.

Yeah dual monitors in OSX are a tad problematic. It completely slipped my mind that it could have been due to this, but I was going on the premise that it worked before with the no issues.

Good news is it finally prompted me to add a note to my mac/osx quirks document, which I've been lax of late to update.

Again thanks for your help.
: Re: Game doesn't run on OSX after latest patch
: x4000 August 07, 2016, 09:36:30 PM
It's my pleasure!