Arcen Games

Games => Starward Rogue => Topic started by: Viykis on November 02, 2016, 07:08:16 PM

Title: Black window on launch under macOS Sierra (10.12.1)
Post by: Viykis on November 02, 2016, 07:08:16 PM
I just purchased the game from Arcen (not Steam, Humble, etc) and I'm getting a black window with a system title bar on launch.  The game doesn't crash, but there's a black screen with no sound and nothing else happens.  I eventually quit the app with CMD-Q.  This is on a laptop with no external monitor connected.  The same thing happens when I try on a newer machine (also a laptop) with the same OS.

Here are my system specs:

Operating System: macOS Sierra (10.12.1)
Processor: 2.4 GHz Intel Core 2 Duo
RAM: 8GB
Video: NVIDIA GeForce 320M 256 MB

Grasping at straws, I reinstalled an old version of Bionic Dues I have laying around... and had the same thing happen.  That was working under 10.11.x.  Could this be a compatibility issue with the latest release of macOS?  Is there any additional information that may be helpful?
Title: Re: Black window on launch under macOS Sierra (10.12.1)
Post by: x4000 on November 13, 2016, 11:53:45 PM
So sorry about the delay!! Thank you for emailing me, I completely missed it. Evidently apple has added a new "app translocation" feature to Sierra, which causes all sorts of chaos for many games that are delivered via means other than Steam or the App Store. The steam versions should not have this issue.

That said, fortunately there is a workaround and it is kind of silly. In Finder, evidently just make any other folder and drag the game into that folder. App translocation then gets turned off and all is well.

There are more details here: http://lapcatsoftware.com/articles/app-translocation.html

Again, sorry for the delay!
Title: Re: Black window on launch under macOS Sierra (10.12.1)
Post by: Viykis on November 14, 2016, 10:01:04 AM
That did it, thanks!
Title: Re: Black window on launch under macOS Sierra (10.12.1)
Post by: x4000 on November 14, 2016, 10:05:57 AM
Whew!  Okay, glad to know it -- thanks for confirming, and for your patience!