General Category > Skyward Collapse Technical Support

I only get a black screen


I was able to play Skyward Collapse after I first downloaded it. But the next time I tried to launch, all I get is a black screen with music playing in the background. Actually, that's not quite accurate, for just a second I see the menu on the left had side flash up, then it goes away.

I think the opening movie is playing or something, but I can't seem to skip past it. Clicking does nothing, and the only keyboard command that works is Command-Q to quit out (I'm on a Mac). Or Shift-Tab to bring up the Steam overlay. I have a 15inch retina display MacBook Pro, and I have the automatic graphics switching off. I tried adjusting the resolution, and restarting but non of that made a difference. Any ideas?

Hi there, sorry to hear of your troubles.  There actually is no intro movie, so it's definitely not that.  Haven't been any updates lately to the game either, so it shouldn't be anything there, either.

A couple of things to try:

1. Verify your local steam cache, so that it can fix anything that got messed up somehow.

2. Take a look in the install folder of the game, under RuntimeData, and post any error messages that might be there.

3. Take a look in the install folder of the game, and rename settings.dat to something like settings2.dat.  Then delete settings.bak and start the game.  That will reset your settings to the default, so any issues there would resolve themselves.

Hope that helps!

Hi. I'm having an extremely similar problem as Icemink.

I tried verifying the local cache. Did not work.

Attached is the Debug Log which is suspiciously devoid of interesting errors.

I tried changing Settings.dat to Settings2.dat, but could not find the mentioned Settings.bak file mentioned.

I also tried deleting the game and reinstalling, which also did not work.

Only difference from Icemink:
When I start the game, in the middle of the screen is GameInit (0 - 11/18/2013 7:53:15 PM) and then it cycles through the other GameInits in the attached list before going black.

I'm running a 2010 Macbook Pro with OS X Mavericks. Anything else I can try?

Update: Although non-optimal, disabling the Steam overlay fixes the issue.

Hi djriverside, thanks for the update on what worked for you.  That's a frustrating issue indeed, but I'm glad there is a workaround.  I will bring this up with Steam and see if there is any sort of fix they might be able to put in on their side to fix this.


[0] Message Index

Go to full version