Author Topic: Hebe and Midgard Bug  (Read 894 times)

Offline Wordsmith

  • Newbie Mark III
  • *
  • Posts: 34
  • Gunter Glieben Glauchen Globen
Hebe and Midgard Bug
« on: May 28, 2013, 08:55:19 PM »
So, as a big fan of A.I. War: Fleet Command, I picked up Skyward Collapse pretty much on release, but haven't really had the opportunity to play it much since then. Today, I settled in for my first real game, with plenty of time to get going.

Brief aside to the bug report: love this game, maybe as much as A.I. War. Absolutely fantastic in both concept and execution. But I think I've found a bug, and as it involves the Mythology Token system, I figured I should report it before other people start having the same issue.

The situation was this: I had gotten into the Age of Monsters, about Turn 38, and everything was going fine. Well, fine enough. Pretty sure it would all have exploded soon, but whatever. That's not the point.

A few turns previously, I had gotten a rude awakening about how horribly unbalanced I had made the Red (Norse) and Blue (Greek) sides in terms of military strength. The Greeks had two cities, both fairly well built up, and a handful of powerful military units. To counterbalance this, I had given the Norse three cities, all with at least one Barracks and Siege Workshop. This, of course, meant a flood of Norse units, and the Greeks' main city was getting absolutely hammered (thanks, in part, to a Frailty Woe that had popped up and decided to stick around, but still). Much of the city was ruins, and this left the Greeks in a bad position, so when I discovered that the Norse Midgard Mythology Token would remove the ruins and allow the Greeks to rebuild, I jumped at the chance and summoned Midgard at the earliest opportunity.

So far so good. Ruins removed, no real damage done to either side. But then a Lockdown Woe showed up, and I decided that I didn't really want to deal with that, and had the Greeks use the Hebe Token. That worked fine as well, for two turns. Then, so far as I can tell, one of two things happened and everything went to crap.

Following the end-of-turn unit animations sequence (which I skipped, since the Norse were still flooding the field and I didn't want to sit through them bashing on the Bandit Fortress again), the game locked up. I could still move the camera around and hover over units and tiles to get information, but the action bar for the Red side never showed up, so I couldn't actually continue the game. I figured it was just a minor glitch, saved, and reloaded.

That got the action bar to come back, but now the game thinks that there's no Lockdown going on (or a Siegfried Is Hired! incoming, which there was). Instead, it thinks that Thanatos' Gathering will be happening in nine turns. Beyond that, it thinks I have under -1,500 points (I was over 2,000 previously), the "Points By Turn" counter thinks I'm still waiting for turn 30 rather than turn 60, and Ares is suddenly standing on Obsidian when there hasn't been any magma on the field.

In looking over the field (screenshot attached below), I noticed that the Hebe Token's tile was destroyed by Midgard during the last end-of-turn sequence (it was previously just behind Laodicea). As far as I can tell, Midgard destroying that tile destroyed the Hebe Token itself, which caused the game to forget what was going on with the Woes. And, from there, it forgot what was going on with my score, or something. It's either that, or Midgard doesn't play nice with Gods, and Ares' tile being replaced with obsidian is the sign of some issue with that instead.

I'm not particularly fussed about the loss of this session, but I figured it'd be best to let people know about this in case it points to a bigger underlying issue. Hope this helps, and let me know if there's anything else I can tell you that might help.

Cheers!

"Sometimes it is better to light a flamethrower than to curse the darkness."
 - Terry Pratchett

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 30,700
Re: Hebe and Midgard Bug
« Reply #1 on: June 14, 2013, 12:55:19 PM »
Sorry about the delay on responding to this!  But it has been fixed since this report.  Cheers! :)
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!