General Category > Skyward Collapse LPs/AARs

[alpha feedback] Some thoughts as I played through


Just finished playing my first Skyward Collapse session which lasted 1 Hour 47 minutes apparently (video playthrough plus chat comments available minus audio...) -- damn, just went to load up my save game to see how far I got and I now realise that I forget to save the game. Thought it was auto-save or something. Oh well, I only got to around Turn 15 I think in round 1. Yes, I play very very slowly.

Oh, well, onto the feedback. This is roughly my thoughts as I played it through.

Upon loading the game the title screen looked nice apart from a weird set up to the initial menu items. That big blank non-menu-item in the top left
looks quite peculiar without the beta-update selection present. Nice music. Upon starting a new game I wasn't sure what settings to select so just went
with the default and into the tutorial.

Initial tutorial text seemed simple and useful. I also liked the slightly comical informal writing referring to the mortals as "dudes" and "plopping" stuff down. Initial zoom in effect impressed me. Got to grip with the controls pretty quickly although I now realise that I never used the zoom scroll after first testing it out. Was zoomed right out for the entire game. The control panel on the left seemed pretty nice. The information at the top of the screen, not so impressive. Just struck me as a little cheap. Spent a bit of time reading all the menu descriptions on the left.

My first attempt at building a barracks confused me as I was trying to build on a tile and not create a new tile. Encountered an interface niggle, it seemed
intuitive to me to bring up a panel with left click (building etc) and then to get rid of it by mousing over an empty area and left-clicking again, however,
only right-clicking worked. Haven't quite got used to that still. I keep left clicking. At this point I'm a little overwhelmed as to what I'm actually supposed to be
doing. Got the barracks built and mousing over it seemed to produce a huge wall of text which was not the easiest to read -- horrific wall of text was my
comment. The presentation on this could be a lot better I think. The wall of text also obscured the placement of the barracks a bit. While looking for
things to build, the text "Missing: Woodcutter (or whatever)" was confusing me as I thought I couldn't build it, but in the tutorial phase I think you can, nevertheless,
can't you?

Aesthetic thing: can't the blue or red border extend around the panels that pop up? Also a red or blue border for the menus that you get when you hover over
a faction tile might be nice.

Plopped down a few buildings and ended both turns. The "hopefully you're not getting too overwhelmed" text helped a bit as I wasn't really sure what I was
doing. Onwards, and still getting confused as to where I'm allowed to build stuff. Some of the help text seemed contradictory. I'll double check this and put it on Mantis if something is wrong. I'm just plopping stuff down now without much thought. Scanning the area for green bits.

Upgrading only producing a health boost was surprising.

Finally got to the playback bit which was pretty cool. Up to this point I was getting a bit disillusioned, not knowing what do do and with seemingly not much
happening. It was cool to see the pieces move around the board after pressing play. Shame something like this wasn't in AVWW2. Really makes the end of turns
more exciting. Found a soldier double KO funny for some reason. Something is starting to click with the gameplay now after maybe an hour's slowly messing around. Skipped through a couple of rounds just to see what would happen next in the playback.

Getting into it now although struggling to keep the track of my resources. Where are the bacon and sword stats..? Is placing grass like wasting an action?
Tried to place a forest tile which wouldn't place anywhere so gave up. Watching events on turn end unfold is cool, although an option to always view all movement might be nice, on the settings menu possibly.

Run into my first problem -- very little logs on one side. Tried placing some logs on the map with a power. Put a couple down yet it says "can be used 1 times" -- not sure what that means. No logs so can't build. Tried placing lumber, but the guys don't collect it. Keeping the reds at bay although their score is piling up. Desperately put down 5 chapmen. Please just get the logs. Keeping the Blue forces at bay by beefing up my one soldier with upgrades. Starting to dig the gameplay a bit now. Brain starting to think about how I can keep the balance although am hamstrung by a lack of logs. Quit for now although I started to enjoy the challenge and concept of the game.

That's about it for now, but definitely excited to play some more. I was very very slow in my progress, but now it feels like things have clicked a bit and I can proceed much more quickly.

Overall, seems good, all there was a period where I was getting a big overwhelmed and bored during the tutorial phase. This was partly due to my own choice of being so slow early on. Could maybe have just plopped stuff down and sped through to the good stuff, which is when the playback stuff happens. My feedback will try to be more refined from now on though.


[0] Message Index

Go to full version