Author Topic: nVidia 650M (304.48 beta driver) - fullscreen crash when starting game  (Read 2776 times)

Offline mixvio

  • Newbie
  • *
  • Posts: 3
I started a mantis issue about this but I figured it couldn't hurt to repost it here and hope it got more eyeballs.

http://www.arcengames.com/mantisbt/view.php?id=8652

Quote
When launching AVWW using the latest beta driver from nVidia for the 650M GPU, the game initially launches fullscreen, but a moment or so later flickers to black and then the game appears inside a cropped window (I think the resolution is something like 500x400 or so). The game itself is rendered within that window at the appropriate resolution, but as that resolution is larger than the game window everything is cropped. As this is a card using Optimus the only workaround is to force the game to use the Intel 4000 card under the nVidia control panel, which allows the game to be launched fullscreen without trouble. However, performance is affected as a result.

Offline tigersfan

  • Arcen Games Contractor
  • Arcen Staff
  • Master Member Mark II
  • *****
  • Posts: 1,599
Just so others who didn't see the Mantis ticket know. This really isn't an issue we can do anything about. This looks like a bug in NVIDIA's driver.

Offline zebramatt

  • Master Member Mark II
  • *****
  • Posts: 1,574
Do Ponies help?

Offline eRe4s3r

  • Core Member Mark II
  • *****
  • Posts: 2,823
Try to use 295.73 or some other pre 300 version. And sadly, ponies do not help this time  ;)

The R300 driver series is entirely borked, even the WHQL certified ones.
Proud member of the Initiative for Bigger Weapons EV. - Bringer of Additive Blended Doom - Vote for Lore, get free cookie

Offline keith.lamothe

  • Arcen Games Staff
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 19,505
The R300 driver series is entirely borked, even the WHQL certified ones.
It's nothing like what was happening in the ATI-ponies thread, but when I hear things like that... where did we as a species go wrong, that such things are possible? :)
Have ideas or bug reports for one of our games? Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline eRe4s3r

  • Core Member Mark II
  • *****
  • Posts: 2,823
Nvidia outsourced driver development to India and the people doing R300 are not the ones who did R200 drivers, thats where ;) The 295 and 296 series were the last drivers without issues for me.

But really, a crash is nothing, for me the r300 and r301 drivers refuse to go out of 2d-low-power mode after standby. Like literally, my card is stuck in low power mode after resuming from standby until I reboot. ;) I would rub a pony over it but ponies are too large and don't fit on my gpu ,p
Proud member of the Initiative for Bigger Weapons EV. - Bringer of Additive Blended Doom - Vote for Lore, get free cookie

Offline mixvio

  • Newbie
  • *
  • Posts: 3
Just so others who didn't see the Mantis ticket know. This really isn't an issue we can do anything about. This looks like a bug in NVIDIA's driver.

I downgraded back to 295.93 (the only driver presently available for the 650M other than the beta one, as the GPU has only been available for a few months) and the fullscreen crash still happens.

The only workaround continues to be forcing the game to use the Intel card instead of the Nvidia one.

ETA: I deleted the driver again completely, along with the AVWW directory, and reinstalled both; now the crash seems to not happen any longer.
« Last Edit: June 26, 2012, 05:10:46 AM by mixvio »

Offline eRe4s3r

  • Core Member Mark II
  • *****
  • Posts: 2,823
So you are using R295 and it works despite the 650M being so new? That would be special. ^^

Also sorry for forgetting to mention you need to uninstall the driver before a downgrade... It is generally advisable that when going from NEW to OLD you always need to do a clean swipe but from OLD to NEW you generally don't even need to reboot. Vista/W7 can actually update the GPU driver on the fly nowadays just not downgrade ;p
« Last Edit: June 26, 2012, 07:09:57 AM by eRe4s3r »
Proud member of the Initiative for Bigger Weapons EV. - Bringer of Additive Blended Doom - Vote for Lore, get free cookie

Offline mixvio

  • Newbie
  • *
  • Posts: 3
Also sorry for forgetting to mention you need to uninstall the driver before a downgrade...

I had, evidently you have to uninstall AVWW as well.

Offline eRe4s3r

  • Core Member Mark II
  • *****
  • Posts: 2,823
Mhhh, might be a Unity related issue when it comes to 2 different GPU devices as well then, it's probably possible it called the device list and got back something that looked like a GPU but wasn't and this might explain the crash too, if it called the wrong device because of some driver quirk it won't ever be able to call your 650M.

Actually, this would perfectly explain the error message as well (which would indicate the engine not actually FINDING a d3d device, ie a GPU) that alone can not possibly be just a driver bug.

Actually, did you start AVWW for the first time with the Intel GPU in use? Because you might have trained it that way to use the intel GPU and it got seriously confused when you wanted to use the 650M instead.
« Last Edit: June 26, 2012, 07:44:51 AM by eRe4s3r »
Proud member of the Initiative for Bigger Weapons EV. - Bringer of Additive Blended Doom - Vote for Lore, get free cookie