Author Topic: My guy won't stop attacking?  (Read 711 times)

Offline Imagamer

  • Newbie
  • *
  • Posts: 2
My guy won't stop attacking?
« on: April 25, 2012, 05:46:34 PM »
Anything I put into slot two of my abilities bar, my guy will spam it uncontrollably. Doesn't matter if it's crates or Fire Touch, he will keep using it as fast as he can. I already tried unbinding all the keys for that command, but no dice.

Offline Hyfrydle

  • Hero Member
  • *****
  • Posts: 587
Re: My guy won't stop attacking?
« Reply #1 on: April 25, 2012, 05:50:41 PM »
Do you have a game pad attached at all?

Offline Imagamer

  • Newbie
  • *
  • Posts: 2
Re: My guy won't stop attacking?
« Reply #2 on: April 25, 2012, 05:55:41 PM »
No, but I didn't unbind the gamepad button from that command, since it wouldn't let me. I have a hunch that MotionInJoy, a program that allows me to use my ps3 controller as a gamepad, may be the culprit. But I don't have it running right now, so I'm a bit confused.

Edit: Problem solved. I looked around in the game's files and found inputbindings.dat (It's in the RuntimeData folder). From there, I manually unbinded the gamepad from that command.
« Last Edit: April 25, 2012, 06:06:05 PM by Imagamer »

Offline Hyfrydle

  • Hero Member
  • *****
  • Posts: 587
Re: My guy won't stop attacking?
« Reply #3 on: April 25, 2012, 06:11:14 PM »
Good stuff glad you got it sorted.

Offline keith.lamothe

  • Arcen Games Staff
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 19,505
Re: My guy won't stop attacking?
« Reply #4 on: April 25, 2012, 08:26:16 PM »
Welcome to the forums :)  Glad to see the problem's already dealt with, but I don't understand exactly what you mean by "but I didn't unbind the gamepad button from that command, since it wouldn't let me."

This should work regardless of whether you have a gamepad plugged in or whatever:

1) Open Settings Window
2) Click Controls button
3) Click Abilities
4) Next to Use Ability 2 (may need to go to the next page of the tab for this, I forget), click the Edit button
5) Left-click the button showing the joystick binding.
6) Now that it's waiting for you to press the new button you want it bound to, right-click to set it to "None" (I think some of them ask you to press Escape for "bind to none" but I don't think this is one of them).

At what point does that process break down (for, say, Ability 3 since you already fixed Ability 2)?

Thanks :)
Have ideas or bug reports for one of our games? Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline dwpenney

  • Newbie
  • *
  • Posts: 1
Re: My guy won't stop attacking?
« Reply #5 on: April 26, 2012, 06:22:51 PM »
In my case Ability 1 is trapped and I can not null (clear/None) it. My toon is firing continuously and following the directions above does not clear the GamePad/Mouse Axis setting (it reads Gamepad 3 (pos)). If I press the right mouse button (to clear it) it gets re-assigned immediately. I see a brief message (on spamming the right mouse button) about pressing the right mouse button to clear but it appears that the mapping immediately returns.

The developers might want to rethink the auto assignment of game controllers. I have a Thrustmaster Warthog (among another 4 controllers for flight simming) that is being detected as a game controller and I am not about to unhook all of these controllers for this. Sorry. :-(

For me to fix it, I edited the inputbindings.dat file and changed this:

KeyBinding:Ingame_UseAbility1|Alpha1|Keypad1|None|None|None|None|Positive3rd|10
KeyBinding:Ingame_UseAbility2|Alpha2|Keypad2|None|None|None|None|Negative3rd|10

to this:

KeyBinding:Ingame_UseAbility1|Alpha1|Keypad1|None|None|None|None|None|10
KeyBinding:Ingame_UseAbility2|Alpha2|Keypad2|None|None|None|None|None|10