General Category > AVWW Technical Support

Mac controller support?

(1/4) > >>

Hi folks!

I have the direct-download versions of Valley 1 & 2 for Mac. I can easily find the bindings section of the in-game settings, and set it to the default Xbox 360 controller settings. However, I can't get it to recognize my wired Xbox controller (latest drivers for Yosemite from here: or, in fact, a Bluetooth PS3 controller, which has native support on Macs. Am I missing a step somewhere? Is there a config file somewhere I should edit instead?


Hey there!

Sorry for your troubles.  You know, I just did update to Yosemite this past week, after being on Mavericks for years.  I kind of tried to stay behind the times since I figure most user issues would be with older stuff.  Funnily enough, my 360 controller stopped working on Yosemite at all, and it wasn't until after your post I realized that had happened for some reason other than my recent installation of Parallels 10.  My 360 controller is working fine on there.

Anyway, long story short, I updated my driver to a similar one to what you have, and now my controller works great in the other games I've tried from my Steam library.  Like you, though, I'm having trouble with the bulk of the Arcen titles.  Grr.  However, The Last Federation and Stars Beyond Reach, both of which are on a newer version of unity 3D, both work fine with it.  So it's something to do with the older version of unity the other games are compiled with. 

Ironically, apparently the v5 unity builds that some other games are using, which are newer than what we choose to use even for our latest games, are again broken on Yosemite for the 360 controllers.  Woohoo... so I expect we'll run into other unity 3D games that are busted for these controllers in our respective libraries.

Anyway, all of this is a roundabout way of saying that I can duplicate your problem, and that:
1. The earlier version of unity 4.x does have this problem (but only on Yosemite), and that's what this game is on.
2. The later versions of unity 4.x do not currently have that problem, and that's what I'll upgrade this to this week.
3. The even-later versions of unity, the 5.x branch, apparently have this problem anew (again only on Yosemite).  I don't plan on upgrading to them.

There is an external input manager called Rewired that I really want to start using, and backport into our older titles as well.  It's a lot more flexible in a lot of different ways, works on all of the above versions of unity, and doesn't have any compatibility issues of these sorts.  So, longer-term that's going to be my solution, but in the short term a simple unity version upgrade on my part ought to do the trick.

I'll post here again when I have an actual fix for the current problem, hopefully tomorrow.  But I figured I'd go ahead and let you know what I've found so far.  Thanks for your patience!

Great, thank you for the update! I'll keep my eyes peeled, then.

Okay, I have not yet gotten to Valley 2, but Valley 1 is now updated and is working with my mac:

It was a bit more of a bear than I had anticipated, because for whatever reason the way the bindings are detected is really different between the OSX driver and the windows driver for the 360 controller.  So I had to remap everything, plus my right trigger was constantly activated, which was super annoying.  Adjusting the dead zone does not fix that.  I'm not sure what that's about.  But anyhow, I made a new default binding just for OSX 360 controllers, and that's now in the list for you to use and then further customize if you don't fully like it.

Eventually I want to switch to the Rewire unity 3D plugin, which should avoid those issues with the dead zone, but for now it's not too big a thing and all the other axes work just fine.  Now that I know what's what, I should have an easier time updating Valley 2 tomorrow, but for now it's pretty late and I'm beat.

Thanks for your patience!

Awesome, thanks! Can't wait to try it out. Please see my other post (in the Tech Support forum for Tidalis), though. Long story short, the direct download version of that game crashes after I run the Updater, forcing me to redownload the older version (and not update it). I saw that Valley 1 already had 1 or 2 updates it wanted to download, but hopefully, this won't also cause this game to crash afterwards!


[0] Message Index

[#] Next page

Go to full version