Arcen Games

Games => A Valley Without Wind 1 & 2 => AVWW Technical Support => Topic started by: drpuppet on July 11, 2015, 04:34:37 PM

Title: Mac controller support?
Post by: drpuppet on July 11, 2015, 04:34:37 PM
Hi folks!

I have the direct-download versions of Valley 1 & 2 for Mac. I can easily find the bindings section of the in-game settings, and set it to the default Xbox 360 controller settings. However, I can't get it to recognize my wired Xbox controller (latest drivers for Yosemite from here: or, in fact, a Bluetooth PS3 controller, which has native support on Macs. Am I missing a step somewhere? Is there a config file somewhere I should edit instead?

Title: Re: Mac controller support?
Post by: x4000 on July 12, 2015, 03:57:39 PM
Hey there!

Sorry for your troubles.  You know, I just did update to Yosemite this past week, after being on Mavericks for years.  I kind of tried to stay behind the times since I figure most user issues would be with older stuff.  Funnily enough, my 360 controller stopped working on Yosemite at all, and it wasn't until after your post I realized that had happened for some reason other than my recent installation of Parallels 10.  My 360 controller is working fine on there.

Anyway, long story short, I updated my driver to a similar one to what you have, and now my controller works great in the other games I've tried from my Steam library.  Like you, though, I'm having trouble with the bulk of the Arcen titles.  Grr.  However, The Last Federation and Stars Beyond Reach, both of which are on a newer version of unity 3D, both work fine with it.  So it's something to do with the older version of unity the other games are compiled with. 

Ironically, apparently the v5 unity builds that some other games are using, which are newer than what we choose to use even for our latest games, are again broken on Yosemite for the 360 controllers.  Woohoo... so I expect we'll run into other unity 3D games that are busted for these controllers in our respective libraries.

Anyway, all of this is a roundabout way of saying that I can duplicate your problem, and that:
1. The earlier version of unity 4.x does have this problem (but only on Yosemite), and that's what this game is on.
2. The later versions of unity 4.x do not currently have that problem, and that's what I'll upgrade this to this week.
3. The even-later versions of unity, the 5.x branch, apparently have this problem anew (again only on Yosemite).  I don't plan on upgrading to them.

There is an external input manager called Rewired that I really want to start using, and backport into our older titles as well.  It's a lot more flexible in a lot of different ways, works on all of the above versions of unity, and doesn't have any compatibility issues of these sorts.  So, longer-term that's going to be my solution, but in the short term a simple unity version upgrade on my part ought to do the trick.

I'll post here again when I have an actual fix for the current problem, hopefully tomorrow.  But I figured I'd go ahead and let you know what I've found so far.  Thanks for your patience!
Title: Re: Mac controller support?
Post by: drpuppet on July 13, 2015, 11:46:48 AM
Great, thank you for the update! I'll keep my eyes peeled, then.
Title: Re: Mac controller support?
Post by: x4000 on July 13, 2015, 09:31:26 PM
Okay, I have not yet gotten to Valley 2, but Valley 1 is now updated and is working with my mac:

It was a bit more of a bear than I had anticipated, because for whatever reason the way the bindings are detected is really different between the OSX driver and the windows driver for the 360 controller.  So I had to remap everything, plus my right trigger was constantly activated, which was super annoying.  Adjusting the dead zone does not fix that.  I'm not sure what that's about.  But anyhow, I made a new default binding just for OSX 360 controllers, and that's now in the list for you to use and then further customize if you don't fully like it.

Eventually I want to switch to the Rewire unity 3D plugin, which should avoid those issues with the dead zone, but for now it's not too big a thing and all the other axes work just fine.  Now that I know what's what, I should have an easier time updating Valley 2 tomorrow, but for now it's pretty late and I'm beat.

Thanks for your patience!
Title: Re: Mac controller support?
Post by: drpuppet on July 13, 2015, 11:07:17 PM
Awesome, thanks! Can't wait to try it out. Please see my other post (in the Tech Support forum for Tidalis), though. Long story short, the direct download version of that game crashes after I run the Updater, forcing me to redownload the older version (and not update it). I saw that Valley 1 already had 1 or 2 updates it wanted to download, but hopefully, this won't also cause this game to crash afterwards!
Title: Re: Mac controller support?
Post by: drpuppet on July 13, 2015, 11:31:53 PM
Man, I just don't have any luck with Arcen games. I clicked the Updater in the AVWW menu. It switched to the Updater window, which seemed to show that everything had gone fine. But now I get the error "Can't open the application AVWW" when I try to run the game again! And I think it only got through the first official update.
Title: Re: Mac controller support?
Post by: x4000 on July 14, 2015, 11:56:07 AM
Okay, whew, goodness.  Here's the skinny:

1. First off, there is a new build that you can download direct from our website that is just the new version straight up:

2. Secondly, I've updated the updater zip package, so from the old installer you now get two extra files:


DIR=$( cd $( dirname ${BASH_SOURCE[0]} ) && pwd )

cd $DIR

chmod a+x ./
find ./ -exec chmod a+x {} \;
chmod a+x ./AVWWLinux.x86
chmod a+x ./AVWWLinux.x86_64
cd UDA
chmod a+x ./ArcenUpdater_Linux.x86_64
chmod a+x ./ArcenUpdater_Linux.x86
chmod a+x ./
find ./ -exec chmod a+x {} \;

Quick Background
Ack!  Unfortunately on some later versions of OS X (such as Yosemite), when we update the game’s underlying engine via the in-game updater, it loses the proper execute flags on the files.  Older versions of OS X did not do this.

We do underlying upgrades of the Unity 3D engine pretty rarely, and it’s only during those engine upgrades that this becomes an issue.  If you are finding that you are unable to run the game because it says that it “cannot be opened,” then most likely this is your problem.

We’ve created a handy script called fix_mac_permissions.command that you can double-click in Finder in order to have it properly set all the permissions on the game and updater files.  Easy peasy.

Possible Problem #2
But!  There’s a good chance that when you try to run fix_mac_permissions.command, it tells you that you don’t have permissions to do THAT.  Good grief!

This seems to be the new security stuff from OS X trying to be helpful and downgrading permissions in such a way that you can’t run it.  The dialog in finder tells you to right-click it and go into Get Info, but that is actually wrong.

What you have to do is open a Terminal window instead, and then type one quick command.

Where Is Terminal?
If you go under Launchpad and just start typing “Terminal,” it should come right up.  If you prefer to look for it under Applications, then it should be under the Utilities folder.

The Terminal Command To Run
At the terminal prompt, please type the following (minus the quotes around it):
“chmod 755 “

Please note that I left an extra space after the 755.  Then go into the folder that has fix_mac_permissions.command in it, and drag that file into your terminal window.  It should create a full command something like this (again minus the quotes):

“chmod 755 /Users/chris/Documents/ArcenGameName/fix_mac_permissions.command”

Hit return/enter, and it will execute.  Seemingly it does absolutely nothing, which is normal.  Now double-click the fix_mac_permissions.command file, and it should run and set all the permissions properly on your game.  You are then free to actually run the game and it will work properly until/unless we do another engine upgrade for unity 3D.

Apologies for all this
Again, really sorry about how much of a pain this is.  Linux and windows don’t have this issue, and older versions of OS X didn’t have this issue, either.  This is something new with the helpful safety features that came in around the time of Yosemite.  Hopefully this will be something that Apple adjusts in the future, but in the meantime we’ve tried to make this as few steps as possible for you.

Thanks for your support of our games, and we hope that you enjoy your newly engine-upgraded version of it!

Hopefully the contents of the second file explain everything satisfactorily so folks don't have to dig up this forum post or anything like that.  Now that that's all settled, I can take a look at Tidalis and Valley 2.  Thanks for your patience!
Title: Re: Mac controller support?
Post by: drpuppet on July 14, 2015, 02:58:31 PM
Very helpful details, thank you! I just downloaded the new build, and will try it tonight. Is a demo version that I will need a code to unlock? I was actually sent links to download full versions by Josh (I am not supposed to share them publicly, but they start with your website URL), since the Steam versions were crashing on me (perhaps the same permissions issue). Anyway, point is, I don't have any demo-unlocking codes, if I will in fact need them.
Title: Re: Mac controller support?
Post by: x4000 on July 14, 2015, 03:53:55 PM
Sure thing!  I have finally gotten Valley 2 working now as well, and that is now also updated on our site (the demo and key version).

For your Steam version, most likely the solution is actually pretty straightforward there: disable the steam overlay in the properties for the game (right click game name in steam listing), and I imagine the steam version should then work for any of the related games.  The keyless version is something that I'm still uploading (sloooowwly, bah), but if you need the later version of that I can PM them to you.

Even with your current version of the direct download game, though, you can run the installer on that, then run the little fixer thing via the instructions above, and that will then work just fine.  It's only a minor permissions things (OSX stripping off the execute flag on things from the internet).
Title: Re: Mac controller support?
Post by: drpuppet on July 14, 2015, 08:18:04 PM
I had read about the Steam overlay thing, I believe, but I don't think it worked. Ok, I'll try running the permissions fixing thing instead, then, and let you know how it works out! But you might have finished uploading before I get around to it, so yes, please PM the links as well.
Title: Re: Mac controller support?
Post by: x4000 on July 14, 2015, 08:20:44 PM
Gotcha, sounds good -- I pm'd you the links!
Title: Re: Mac controller support?
Post by: drpuppet on July 15, 2015, 11:40:24 AM
Thanks, I am downloading them as I type this! For future reference though, where should I be able to find the "fix_mac_permissions.command" file? I can't seem to locate it in any of the Arcen game folders, but I am probably overlooking something. And is it also included with the Tidalis version I downloaded directly from this site?
Title: Re: Mac controller support?
Post by: x4000 on July 15, 2015, 11:47:34 AM
That's included in all of the updater files, but I don't think in the direct download files, and I think in the direct download full version files as well -- the new versions only, though.

It's not included in the Tidalis build, but honestly there's no reason to do the beta update on that one anyway if you're not on steam.  The only thing that even changed was some steam integration.  I went ahead and adjusted that so that it won't be trying to download the problematic one.
Title: Re: Mac controller support?
Post by: drpuppet on July 15, 2015, 12:17:57 PM
Oh, ok. So just to clarify, if I redownload Tidalis from the same link I was sent, it should be able to update properly now? In that case, where I can find my saved game folder in the direct-download version, so I can copy those over?

Thanks so much!
Title: Re: Mac controller support?
Post by: x4000 on July 15, 2015, 12:32:15 PM
Sure thing!  Your saves are in:


You may also want:

Title: Re: Mac controller support?
Post by: drpuppet on July 15, 2015, 12:48:26 PM
Sweet, thanks! And I think I read your last message too quickly about not needing to worry about the beta update. Still, I think it listed 2 "official" updates, but I might be getting it mixed up with AVWW at this point! Heh. Either way, I'll redownload it anyway.

And then hopefully I'll be able to leave you alone for a while!
Title: Re: Mac controller support?
Post by: x4000 on July 15, 2015, 01:59:30 PM
Sounds great!