General Category > AVWW Technical Support

Mac controller support?

<< < (2/4) > >>

Man, I just don't have any luck with Arcen games. I clicked the Updater in the AVWW menu. It switched to the Updater window, which seemed to show that everything had gone fine. But now I get the error "Can't open the application AVWW" when I try to run the game again! And I think it only got through the first official update.

Okay, whew, goodness.  Here's the skinny:

1. First off, there is a new build that you can download direct from our website that is just the new version straight up:

2. Secondly, I've updated the updater zip package, so from the old installer you now get two extra files:


--- Quote ---#!/bin/sh

DIR=$( cd $( dirname ${BASH_SOURCE[0]} ) && pwd )

cd $DIR

chmod a+x ./
find ./ -exec chmod a+x {} \;
chmod a+x ./AVWWLinux.x86
chmod a+x ./AVWWLinux.x86_64
cd UDA
chmod a+x ./ArcenUpdater_Linux.x86_64
chmod a+x ./ArcenUpdater_Linux.x86
chmod a+x ./
find ./ -exec chmod a+x {} \;
--- End quote ---


--- Quote ---Quick Background
Ack!  Unfortunately on some later versions of OS X (such as Yosemite), when we update the game’s underlying engine via the in-game updater, it loses the proper execute flags on the files.  Older versions of OS X did not do this.

We do underlying upgrades of the Unity 3D engine pretty rarely, and it’s only during those engine upgrades that this becomes an issue.  If you are finding that you are unable to run the game because it says that it “cannot be opened,” then most likely this is your problem.

We’ve created a handy script called fix_mac_permissions.command that you can double-click in Finder in order to have it properly set all the permissions on the game and updater files.  Easy peasy.

Possible Problem #2
But!  There’s a good chance that when you try to run fix_mac_permissions.command, it tells you that you don’t have permissions to do THAT.  Good grief!

This seems to be the new security stuff from OS X trying to be helpful and downgrading permissions in such a way that you can’t run it.  The dialog in finder tells you to right-click it and go into Get Info, but that is actually wrong.

What you have to do is open a Terminal window instead, and then type one quick command.

Where Is Terminal?
If you go under Launchpad and just start typing “Terminal,” it should come right up.  If you prefer to look for it under Applications, then it should be under the Utilities folder.

The Terminal Command To Run
At the terminal prompt, please type the following (minus the quotes around it):
“chmod 755 “

Please note that I left an extra space after the 755.  Then go into the folder that has fix_mac_permissions.command in it, and drag that file into your terminal window.  It should create a full command something like this (again minus the quotes):

“chmod 755 /Users/chris/Documents/ArcenGameName/fix_mac_permissions.command”

Hit return/enter, and it will execute.  Seemingly it does absolutely nothing, which is normal.  Now double-click the fix_mac_permissions.command file, and it should run and set all the permissions properly on your game.  You are then free to actually run the game and it will work properly until/unless we do another engine upgrade for unity 3D.

Apologies for all this
Again, really sorry about how much of a pain this is.  Linux and windows don’t have this issue, and older versions of OS X didn’t have this issue, either.  This is something new with the helpful safety features that came in around the time of Yosemite.  Hopefully this will be something that Apple adjusts in the future, but in the meantime we’ve tried to make this as few steps as possible for you.

Thanks for your support of our games, and we hope that you enjoy your newly engine-upgraded version of it!
--- End quote ---

Hopefully the contents of the second file explain everything satisfactorily so folks don't have to dig up this forum post or anything like that.  Now that that's all settled, I can take a look at Tidalis and Valley 2.  Thanks for your patience!

Very helpful details, thank you! I just downloaded the new build, and will try it tonight. Is a demo version that I will need a code to unlock? I was actually sent links to download full versions by Josh (I am not supposed to share them publicly, but they start with your website URL), since the Steam versions were crashing on me (perhaps the same permissions issue). Anyway, point is, I don't have any demo-unlocking codes, if I will in fact need them.

Sure thing!  I have finally gotten Valley 2 working now as well, and that is now also updated on our site (the demo and key version).

For your Steam version, most likely the solution is actually pretty straightforward there: disable the steam overlay in the properties for the game (right click game name in steam listing), and I imagine the steam version should then work for any of the related games.  The keyless version is something that I'm still uploading (sloooowwly, bah), but if you need the later version of that I can PM them to you.

Even with your current version of the direct download game, though, you can run the installer on that, then run the little fixer thing via the instructions above, and that will then work just fine.  It's only a minor permissions things (OSX stripping off the execute flag on things from the internet).

I had read about the Steam overlay thing, I believe, but I don't think it worked. Ok, I'll try running the permissions fixing thing instead, then, and let you know how it works out! But you might have finished uploading before I get around to it, so yes, please PM the links as well.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version