Author Topic: Why aren't my turrets firing?  (Read 1243 times)

Offline Quitch

  • Full Member Mark II
  • ***
  • Posts: 154
Why aren't my turrets firing?
« on: June 10, 2009, 06:21:54 PM »


AI bomber comes through wormhole to two tractor beams, two MLRS and two short-range turrets. Bomber is firing, tractor beam captures, but none of the shooty turrets fire.

Note in the shot how far through reloading the bomber is but none of mine have reload bars. Included range count of MLRS to show they should be in shooting distance.

This is 1.0006A

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,051
Re: Why aren't my turrets firing?
« Reply #1 on: June 10, 2009, 06:31:21 PM »
This ties into how ranging works -- most likely the shields of the bomber are high enough that even though the bomber is inside the range of the turret, the turret has a 0% chance of hitting it.

Basically, just because an enemy ship is inside the Z circle does not guarantee it can actually be hit.  If the enemy has significant shielding, then that reduces the effective size of the Z circle (which isn't shown, because that varies by target).  And if something is at the outside range of the Z circle, there's often a very poor chance of actually hitting the target.  When you have one of your ships selected, you can hover over an enemy ship (in this case the bomber), to see what the percent chance of hitting it is.  Given that Bomber Is have 1500 shields, it's almost a certainty that the shields make the bomber outside the effective range of that turret.

If you'd like more information on how shielding works here's a link to the mini faq:  Do Shots Miss Sometimes?

Hope that helps!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!