Author Topic: [TRANSLATION] [1.999H] National characters don`t work.  (Read 1146 times)

Offline AcidWeb

  • Full Member
  • ***
  • Posts: 127
[TRANSLATION] [1.999H] National characters don`t work.
« on: September 26, 2009, 10:28:43 AM »
When I put any Polish national in language XMLs game don`t recognize entire file - MISSING LOCALISATION
I attached modified mail.xml - MainMen_btnQuit string contains all Polish national characters.

Offline darke

  • Hero Member
  • *****
  • Posts: 534
Re: [TRANSLATION] [1.999H] National characters don`t work.
« Reply #1 on: September 26, 2009, 10:45:09 AM »
Did you save the file as UTF-8 rather then UTF-16?

EDIT: Just to clarify, I have edited the main.xml file, added some Japanese characters, saved it as utf8, and rendered fine adding the characters to the QUIT item in the main menu. Polish, etc should all work fine, you just need to make sure the file is saved in utf8 format not your local code page.
« Last Edit: September 26, 2009, 11:01:19 AM by darke »

Offline AcidWeb

  • Full Member
  • ***
  • Posts: 127
Re: [TRANSLATION] [1.999H] National characters don`t work.
« Reply #2 on: September 26, 2009, 11:06:50 AM »
Ofc I used UTF-8.

EDIT:
Ok. I working now. I don`t know what is wrong after few saves as UTF-8 it started working. It is something wrong with my software not game :)
« Last Edit: September 26, 2009, 11:25:09 AM by AcidWeb »

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,231
Re: [TRANSLATION] [1.999H] National characters don`t work.
« Reply #3 on: September 28, 2009, 10:23:40 AM »
Whew!  Good to know.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!