Author Topic: Updating fails  (Read 1427 times)

Offline chrono43

  • Newbie
  • *
  • Posts: 5
Updating fails
« on: November 03, 2010, 01:34:29 PM »
When I start Ai War it shows that there is one official and one beta update. I click update then download and install all updates. The update gets to around 7% then jumps to 100% and goes to the main menu. Nothing is in the updates folder. Is there something I am doing wrong?

Offline x4000

  • Chris McElligott Park, Arcen Founder and Lead Dev
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,624
Re: Updating fails
« Reply #1 on: November 03, 2010, 02:07:24 PM »
Hmm, that's really unusual, and a new one on me.  It sounds like your connection to the site is getting lost in the middle there.  Are there any error messages in your RuntimeData folder inside the game folder?  What version of the game are you using -- and is it the one from Steam or Impulse?

Also, are you using the Kapersky antivirus?  And, what OS are you on?

That's an odd one, sorry to hear about it!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline chrono43

  • Newbie
  • *
  • Posts: 5
Re: Updating fails
« Reply #2 on: November 03, 2010, 02:33:37 PM »
There are no error messages in the Runtimedata folder. The game version is 4.000 with both expansions. It is from neither Impulse or Steam and I do not use Kapersky antivirus. My OS is Vista Home Premium 32-bit. I use dial-up which is likely the problem.

Offline x4000

  • Chris McElligott Park, Arcen Founder and Lead Dev
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,624
Re: Updating fails
« Reply #3 on: November 03, 2010, 03:44:48 PM »
Hmm, it sounds like that might be it, yes.  That might make using the betas a challenge, but we put out new installers with each full official release (rather than just the minor bugfix one that is 4.021), which would let you get around it.  How long is it taking to get to that 7%?
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline chrono43

  • Newbie
  • *
  • Posts: 5
Re: Updating fails
« Reply #4 on: November 03, 2010, 04:02:37 PM »
It took about 1 minute and 30 seconds to get to 6% before going back to the main menu.

Offline x4000

  • Chris McElligott Park, Arcen Founder and Lead Dev
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,624
Re: Updating fails
« Reply #5 on: November 03, 2010, 04:05:57 PM »
Hmm, it might be some sort of timeout, then... I'll have to poke around and see what I can change on that.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline chrono43

  • Newbie
  • *
  • Posts: 5
Re: Updating fails
« Reply #6 on: November 03, 2010, 04:18:46 PM »
Thank you for taking the time to look into this. If you need any more information let me know.

Offline x4000

  • Chris McElligott Park, Arcen Founder and Lead Dev
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,624
Re: Updating fails
« Reply #7 on: November 03, 2010, 04:21:03 PM »
Will do.  Thanks!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline x4000

  • Chris McElligott Park, Arcen Founder and Lead Dev
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,624
Re: Updating fails
« Reply #8 on: November 03, 2010, 10:02:00 PM »
Okay... bleh, this is a tricky one.  No promises that this fix will work, but it will at least eliminate one big question about it.  Can you try downloading the official update again?  Beta updates are still unlikely to work for you, but the official 4.021 should work if it was a timeout issue on the server host (and if that's true, then I'll have to go back to rackspace support, who said it wasn't).  On the other hand, if it's NOT a timeout issue on the rackspace side, then it must be a timeout thing in the WWW class, which will be kind of a hard roadblock for a while, I expect. :/ 

So I'm hoping it's some sort of server setting thing.  What I've done is switch that one official update over to MediaFire, where we have to pay for bandwidth but where there shouldn't be any timeouts.

Let me know how it does for you, hopefully that's what it was!  Fingers crossed. :)
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline chrono43

  • Newbie
  • *
  • Posts: 5
Re: Updating fails
« Reply #9 on: November 03, 2010, 10:44:27 PM »
It worked. Thank you very much for your help.

Offline x4000

  • Chris McElligott Park, Arcen Founder and Lead Dev
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,624
Re: Updating fails
« Reply #10 on: November 03, 2010, 10:45:42 PM »
Sweeet!  That makes the issue something that I can take back to rackspace, at least!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

 

SMF spam blocked by CleanTalk