Author Topic: Low FPS  (Read 985 times)

Offline FenixFunk

  • Newbie
  • *
  • Posts: 3
Low FPS
« on: September 19, 2014, 07:05:03 AM »
Hi. I have very low fps in game. With vsync turned on it's stable 60 (like it should be), but if vsync is off, I get 40-50 frames per second. What's wrong with it? Its happening even in new single player game without any units on screen or whatever. Must be last update broke something.

My specs (videocard is R9 280x):

« Last Edit: September 19, 2014, 07:22:43 AM by FenixFunk »

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,374
Re: Low FPS
« Reply #1 on: September 19, 2014, 08:50:26 AM »
It's hard to say.

1. What version number of the game are you in?  A lot of improvements have been made recently.

2. Are you in a huge battle at the time?  Thousands of ships vs thousands of ships?  If so, it might just be a ton of calculations.

3. You can try going into the Stats section in the game and adjusting the simulation speed from there.  The game actually only changes the updates of the game at whatever speed is set there, so even if you have a higher FPS it is not drawing game updates any faster (just things like hud movement, scrolling, zooming, etc.

Hope that helps!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline FenixFunk

  • Newbie
  • *
  • Posts: 3
Re: Low FPS
« Reply #2 on: September 19, 2014, 09:45:55 AM »
1. Latest Steam version: 8.014

2. No. Like I said, I started new game and get this poor 40 fps without vsync. My linux friends told me, that they have about 300+ in same conditions.

3. If I set "Insane" (17ms) performance profile in stats, I got static 100 frames per second. Like it has cap or something. Is that right? On "High" (50ms) its just 40 frames. With vsync I always have 60 fps. I guess this is kind of bug or something.

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,374
Re: Low FPS
« Reply #3 on: September 19, 2014, 09:56:10 AM »
It's actually working as intended -- I'm not sure why the linux folks are seeing 300fps, that's something on that platform that really shouldn't be happening.  It gets wasteful of the CPU there.

It sounds like everything is working as it should, based on how the game is designed.  It is indeed framerate capped when vsync is off, and vsync is supposed to basically always be on.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline FenixFunk

  • Newbie
  • *
  • Posts: 3
Re: Low FPS
« Reply #4 on: September 19, 2014, 10:02:49 AM »
Thanks for the answer! I throught it works like in other games - with vsync turned off you get maximum frames without a limit. Well, there is no problem here.
« Last Edit: September 19, 2014, 10:05:44 AM by FenixFunk »

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,374
Re: Low FPS
« Reply #5 on: September 19, 2014, 10:12:55 AM »
Not a problem!

And yeah, I had to turn off the maximum frames with vsync off, because it was causing out of memory errors on some people's machines due to transient memory allocations there.  It _might_ not actually be a problem now with the recently revised sprite batching stuff, but I don't want to tempt fate. ;)  Our other games work like you are expecting, but AI War is one heck of a beast when it comes to the load it puts on the CPU, so it's a bit of an unusual case.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!