Arcen Forums

General Category => AI War Classic => AI War Classic - Technical Support => Topic started by: Astilious on September 22, 2010, 09:31:21 PM

Title: Game Wipe
Post by: Astilious on September 22, 2010, 09:31:21 PM
This is my first forum post ever in anything so I apologise if I have any conventions wrong.

I just updated to the latest beta yesterday and it ran fine (I love the new AI gaurd posts) but today I tried to start it up and it asked me for the licence key. I put that and the zenith remnant one in and go to load my game but find there are no games to load. I check the achievements and find they have also been reset. The game seems to have lost all data for everything. I am running Windows 7 on a laptop with an intel core i7 CPU and a NVIDIA GeForce GTS 250M graphics card. I haven't had any problems with AI war before.
Title: Re: Game Wipe
Post by: x4000 on September 22, 2010, 09:39:17 PM
Welcome to the forum!  Glad you're enjoying the game so well, but sorry to hear of the trouble here.

It sounds like potentially your permissions changed on the folder in question -- there's definitely nothing that would erase all your savegames from within the game itself.  Everything but the savegames are stored in a file called settings.dat, so if that was corrupted or lost then everything but the savegames would be lost, but since the savegames also went that seems suspicious.

If you look at the folder in which AI War is installed, depending on where that folder is you will see a Save directory which may or may not have save files in it.  If it does have save files, you'll want to make sure that the user you are running as has full read/write permissions to the entire AI War runtime folder. 

If it does not have any save files in it, then apparently you have the opposite problem (you recently gained read/write permissions to that folder, such as if you're running as an admin now and had not in the past, or similar).  In that case, your savegames are in a different folder (and your settings.dat file), and you can simply copy them to your main AI War folder.

In windows 7, the folder would be something along these lines: C:\Users\<YourUserName>\AppData\Local\AIWar

It could also be in LocalLow or Roaming inside the AppData folder if you don't see an AIWar folder in the first location.  You should see a settings.dat file, as well as a Save folder -- simply copying those into your AI War runtime folder would get around that. 

Added tip: You can verify what folder AI War is looking in for savegames and settings.dat and such by looking at that big long textbox at the bottom of your Settings window in the game.

Also: if your settings.dat was corrupted, there is a settings.bak that it always tries to load. But, since the savegames are also missing it sounds like the permissions on your machine just changed.

In the upcoming AI War 4.0, we're going to be handling things a bit differently so that the permissions are always automatically set for you in the AI War folder, and thus it always writes to itself rather than sometimes writing to the user cache. That's what we did with Tidalis, and it's proved a lot simpler -- issues like this are rare, but certainly can happen.

Hope that helps!
Title: Re: Game Wipe
Post by: Astilious on September 22, 2010, 10:18:32 PM
Thankyou!

I did find the data in C:\Users\<UserName>\AppData\Local\AIWar. I'm the only user of my computer and I didn't deliberately change the permissions so I can't imagine what caused the change but it seems that was the problem.
Title: Re: Game Wipe
Post by: x4000 on September 22, 2010, 10:20:25 PM
Glad that worked!  Very odd on the permissions, of course.  Maybe it was related to a service pack update or something to windows; sometimes you never know with that.  Glad that solved it, anyway! :)