Arcen Forums

General Category => AI War Classic => AI War Classic - Technical Support => Topic started by: AnatomyOfWar on October 27, 2010, 08:05:56 PM

Title: Error after v4.0 update
Post by: AnatomyOfWar on October 27, 2010, 08:05:56 PM
Today, in anticipation of the update v4.0 and the release of the expansion, i started steam and there was an update before steam launched,
after this i proceeded to buy the expansion CON, i bought it, then after all this i tried to start up AI War, and got the following from the AI War folder, which had a new word file which contained:

10/27/2010 5:15:38 PM (3.1.8.9)
-----------------------------------CurrentDomain_UnhandledException-----------------------------------System.NullReferenceException: Object reference not set to an instance of an object.
   at AIWar.Game.CreateAnimatedCursor(String filename)
   at AIWar.Game..ctor()
   at AIWar.Program.Main()
10/27/2010 5:18:28 PM (3.1.8.9)
-----------------------------------CurrentDomain_UnhandledException-----------------------------------System.NullReferenceException: Object reference not set to an instance of an object.
   at AIWar.Game.CreateAnimatedCursor(String filename)
   at AIWar.Game..ctor()
   at AIWar.Program.Main()
10/27/2010 5:28:09 PM (3.1.8.9)
-----------------------------------CurrentDomain_UnhandledException-----------------------------------System.NullReferenceException: Object reference not set to an instance of an object.
   at AIWar.Game.CreateAnimatedCursor(String filename)
   at AIWar.Game..ctor()
   at AIWar.Program.Main()


and the "AI War has stopped working" details that came up after the failed startup

Description:
  Stopped working

Problem signature:
  Problem Event Name:   CLR20r3
  Problem Signature 01:   aiwar.exe
  Problem Signature 02:   3.0.0.0
  Problem Signature 03:   4c75bdac
  Problem Signature 04:   AIWar
  Problem Signature 05:   3.0.0.0
  Problem Signature 06:   4c75bdac
  Problem Signature 07:   5a
  Problem Signature 08:   29
  Problem Signature 09:   System.NullReferenceException
  OS Version:   6.1.7600.2.0.0.768.3
  Locale ID:   1033

I'm not sure what this is about, because i was playing for hours just yesterday, and it seems after this update, something happened and now it will not start-up,
i've looked at the steam forums, these Arcen games technical support forums and have not found anything similar
Title: Re: Error after v4.0 update
Post by: keith.lamothe on October 27, 2010, 08:08:21 PM
Welcome to the forums :)

Those errors are from version 3.189, the last version that ran on .NET/SlimDX.  4.0 runs on Unity3D, and has nothing to do with animated cursors in that sense ;)

But the timestamp on the errors is current.  Basically it looks like Steam hadn't done the update yet or something.  Can you try updating, and if that doesn't work, reinstalling?
Title: Re: Error after v4.0 update
Post by: x4000 on October 27, 2010, 08:28:11 PM
It looks like what happened in this specific case is that you have half of 3.189, and half of 4.0 -- quite odd, I know.  I would have Steam verify its local file cache, apparently it just didn't fully download the new version!

Hope that helps. :)
Title: Re: Error after v4.0 update
Post by: AnatomyOfWar on October 27, 2010, 08:36:32 PM
I deleted all AI War content from my computer, and reinstalled it and it worked but started out on the trial, after entering the keys for
the core game, and the two expansions, i restarted AI War and everything is all good now. No problems, other than (not really a problem, but the
actual startup process is a bit slower than the previous "pre-4.0" version), but i would imagine that goes with the upgrade to Unity and so on.
Thanks for the help/suggestions.
Title: Re: Error after v4.0 update
Post by: x4000 on October 27, 2010, 08:38:13 PM
Our pleasure!  And that slightly-slower startup makes the startup of actual games faster, and prevents lag in your first battle.  So it's actually net faster than the old versions, just not right at the very first. :)
Title: Re: Error after v4.0 update
Post by: AnatomyOfWar on October 27, 2010, 08:40:05 PM
No complaints here, keep up the excellent updates/expansions, Well done.
Title: Re: Error after v4.0 update
Post by: keith.lamothe on October 27, 2010, 08:40:12 PM
Glad to hear it worked out :)

Please let us know if you run into anything else.