Author Topic: Game not working after 4.032 update attempt  (Read 1757 times)

Offline ttube

  • Newbie Mark II
  • *
  • Posts: 11
Game not working after 4.032 update attempt
« on: November 13, 2010, 12:48:17 PM »
1. Had the game plus both expansions for about two weeks. Downloaded from Impulse and running on Vista-32.

2. My initial update was problematic but you guys at Arcen talked to Impulse and problem solved.

3. Game worked fine and updates worked flawlessly: Until Now!

4. Started the game today and saw that an update was available then clicked on the "download and update" button. The game closed and the update window opened as usual. The update began but seemed to stall halfway through. Norton Internet Security picked up a threat (the executable) and deleted it.  I went into NIS and permitted the executable. I then went into Indie Games (Program files) and started the updating process. It again stalled about halfway through. The update window changed to "Update complete" with "do you want to start AIWars" checked. Clicked on OK the game loads but without any graphics. The opening screen is white with a large pink area in the upper right (where the game names normally appear). My saved game loads but without any graphics. I repeated the update process but with the same results: the game loads but without graphics.

5. It seems to me the the updating was not completed.

Hoping to hear from someone.
TIA


Offline x4000

  • Chris McElligott Park, Arcen Founder and Lead Dev
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,624
Re: Game not working after 4.032 update attempt
« Reply #1 on: November 13, 2010, 01:00:20 PM »
This update upgraded to a new version of unity 3d, and apparently norton didn't like that in your case, and corrupted it in some manner. If you look in your runtimedata/updates folder you should see a zip file for 4.032: if you manually unzip that into your game folder, it should have everything you need to get it working. You can also try running the updater directly from the install folder, and it will unpack that zip file for you in an automated fashion. As long as norton isn't allowed to interfere, that should work. At present, it sounds like it prevented about half the files from beig unpacked, but they're all sitting there on your computer in that 4032.zip file in runtimedata/updates.

Hope that helps!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline ttube

  • Newbie Mark II
  • *
  • Posts: 11
Re: Game not working after 4.032 update attempt
« Reply #2 on: November 13, 2010, 06:55:59 PM »
Thanks for the quick response.
Found the zip file and extracted it into the program file. Started the game but unfortunately the same problem.
Ran the updater, got an error message but continued. Started the game and it loaded successfully. So all is well.
Thanks again.

Offline x4000

  • Chris McElligott Park, Arcen Founder and Lead Dev
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,624
Re: Game not working after 4.032 update attempt
« Reply #3 on: November 13, 2010, 07:54:08 PM »
Very odd -- but glad that did it!  Sometimes antivirus programs can be a bit aggressive.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

 

SMF spam blocked by CleanTalk