Author Topic: Call me stupid - alt names problem  (Read 2283 times)

Offline Nibelung44

  • Jr. Member Mark II
  • **
  • Posts: 75
Call me stupid - alt names problem
« on: February 12, 2011, 11:40:51 AM »
Hi,

I'm under Windows Seven, if this change anything.

I have replaced the altplanetnames.txt file in the Runtimedata directory by alternate names, and this does not change anything, I'm still with the random vanilla names. Can somebody tell me if it happened to him?

I can even delete the file, and I still get the names... And I have only one copy of the game on my HD, in case you wonder if I'm not editing a game and using a shortcut on another copy of it, nope ;)

So? Weird, no?

Offline dumpsterKEEPER

  • Sr. Member Mark II
  • ****
  • Posts: 361
Re: Call me stupid - alt names problem
« Reply #1 on: February 12, 2011, 02:51:27 PM »
Just to be clear, are you fully starting a new game when you're trying this? The alternate names aren't used in the lobby, nor will they apply to any games already in progress.

Offline Nibelung44

  • Jr. Member Mark II
  • **
  • Posts: 75
Re: Call me stupid - alt names problem
« Reply #2 on: February 12, 2011, 05:02:36 PM »
No, I was generating new galaxy layouts in the lobby and saw no change. Rather misleading then. Thanks.

Offline TechSY730

  • Core Member Mark V
  • *****
  • Posts: 4,562
Re: Call me stupid - alt names problem
« Reply #3 on: February 12, 2011, 05:30:37 PM »
No, I was generating new galaxy layouts in the lobby and saw no change. Rather misleading then. Thanks.

Yea it's a little sad that the lobby does not reflect the altplanetnames.txt. I think Chris (x4000) said in the past that it had to do with multi-player synchronization or something, but I don't know.

Offline dumpsterKEEPER

  • Sr. Member Mark II
  • ****
  • Posts: 361
Re: Call me stupid - alt names problem
« Reply #4 on: February 16, 2011, 01:24:00 PM »
No, I was generating new galaxy layouts in the lobby and saw no change. Rather misleading then. Thanks.

Yea it's a little sad that the lobby does not reflect the altplanetnames.txt. I think Chris (x4000) said in the past that it had to do with multi-player synchronization or something, but I don't know.

My suspicion is that it has to do with how the lobby synchronization is handled. If the alternate names were used, then the host would have to transmit those names to all connected players. As it is now, as long as the lobby generation process is deterministic, each player can start from the same point and compute the lobby state for themselves, which uses a lot less network traffic. When the game begins, the planet names can be pushed to all players as part of the initial game state synchronization.

 

SMF spam blocked by CleanTalk