Author Topic: Valley 2 Official 1.500 “Linux Support” Released!  (Read 1840 times)

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 30,699
Valley 2 Official 1.500 “Linux Support” Released!
« on: July 17, 2014, 01:22:03 PM »
Original: http://arcengames.com/valley-2-official-1-500-linux-support-released/

This one brings official linux support to the game for the first time, as well as a 64bit build for OSX.  There is also one minor bugfix in there, too.

License Keys No More


Another nice thing about this version is that the license key that was previously required is now optional instead.  If you have the game on Steam, or you get the new tri-OS package from our store, it won't ask you for the CD key at all.  Steam won't even give you a key, and our store gives you a Steam key now.  If you buy it from us or any other source, then you can use that CD key to register your game on Steam.  They can, of course, still be used to unlock the demo versions of the game into the full version, as well.  You just don't HAVE to do that anymore.

Discount Promotion!

As with Shattered Haven, Skyward Collapse, and Tidalis, we're running a 75% off sale on our site in celebration of the linux launch.  This will last until the 30th for all of these games!

 

Enjoy!

This is a standard update that you can download through the in-game updater itself, if you already have any version of the game. If you have the beta on Steam, it will automatically update for you. When you launch the game, you'll see the notice of the update having been found if you're connected to the Internet at the time. If you don't have the standalone game, you can download that here. If you already own the first game, just use your existing license key to unlock the sequel for free!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline windgen

  • Jr. Member
  • **
  • Posts: 51
Re: Valley 2 Official 1.500 “Linux Support” Released!
« Reply #1 on: July 21, 2014, 06:41:56 AM »

Is anyone else getting "Could not preload global game manager #0" error message?  I filed the problem I'm having as #15579.

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 30,699
Re: Valley 2 Official 1.500 “Linux Support” Released!
« Reply #2 on: July 27, 2014, 02:04:14 PM »
Hey there, sorry about the really slow reply, I've been out of the office and this got missed.  I completely botched the 1.500 patch for windows in terms of actually forgetting to include the, um, updated executable.  So the old version of that executable from unity 3.whatever was not compatible with the new 4.2.1 unity asset files, hence the error you were getting.

I've now updated the update so that anyone else downloading 1.500 won't get that problem anymore.  What to do:

1. For anyone reading this and have installed the update after now, then there's nothing for you to worry about.

2. For anyone using a non-windows version of the game, there's nothing for you to do, either.

3. If you are on windows and are having this issue, then you can manually download this file: http://valley2.s3.amazonaws.com/Valley2_1500.zip  Then unzip that into your base install folder for the game, and that will update you properly to 1.500.  It will then want you to update to 1.501 after that, but your install is not corrupt or in any way harmed by this.  Note: If you want to shortcut this, you can actually even just pull Valley2.exe out of that zip file linked above and replace the version in your install folder with it.  That's all that needs to change; everything else is fine.

Sorry about this, and thanks for your patience!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Ravinius

  • Newbie Mark II
  • *
  • Posts: 14
Re: Valley 2 Official 1.500 “Linux Support” Released!
« Reply #3 on: August 05, 2014, 07:43:36 AM »
Hey after updating the Valley Without Wind 2 to 1.500 there's still one more official update in the menu. After I download it and the new updater starts running it starts the uninstaller for the game instead of installing the update. What gives? Oh and Spectral Empire looks awesome:)

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 30,699
Re: Valley 2 Official 1.500 “Linux Support” Released!
« Reply #4 on: August 05, 2014, 09:46:17 AM »
Hey there, where did you get this version of Valley 2 from?  Our website, or somewhere else?  I wasn't aware of us having an uninstaller in there, but I might be misremembering.  And sometimes other vendors like GOG add in uninstallers of their own.

The updater searches for an executable to run, and is expecting only one.  So if you just remove the uninstaller, then it should work fine.  This may be what is going on with Skyward, too.  If you delete the old autoupdater executable files, then that should handle it.  All the new autoupdater stuff is in the UDA subfolder, so you won't accidentally delete that.

For Valley 2, if you just want a clean install package, you can also get that off our site.  Thanks!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Ravinius

  • Newbie Mark II
  • *
  • Posts: 14
Re: Valley 2 Official 1.500 “Linux Support” Released!
« Reply #5 on: August 05, 2014, 10:50:54 AM »
Removing uninstaller from the game folder worked. As for the version of the game it's the one from royal bundle which I believe is identical to the one on your page.

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 30,699
Re: Valley 2 Official 1.500 “Linux Support” Released!
« Reply #6 on: August 05, 2014, 10:58:54 AM »
Okay, cool -- that does answer that, it is the same one from our page.  I guess Bitrock installs an uninstaller there, I hadn't counted on that.  Grr. ;)  Simply removing that uninstaller on any game where the updater gives you a problem would handle it fine, I think.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!