Author Topic: [Solved] Trouble with the Tidalis License Key in .407  (Read 4352 times)

Offline sil

  • Newbie
  • *
  • Posts: 6
[Solved] Trouble with the Tidalis License Key in .407
« on: May 04, 2010, 06:27:37 PM »
I pre-purchased the game a while back since I really enjoy AI Wars and Tidalis also sounded fun(which it is). Today I finally got around to updating it past .40, which basically involved me uninstalling the previous version(which I'd activated) and then using the .407 installer. Now I cannot seem to get the game to activate. It prompts for the license key at the start. I put it in, press button and nothing happens. If I put in the wrong key it says something, with the right one it does absolutely nothing. I try to play a new adventure or a quick game and the game just reverts to the main screen.

What am I doing wrong?

Now that I play with it a bit more, nothing works since I installed the new version. I used the uninstall program that comes with the game...

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,226
Re: Trouble with the Tidalis License Key in .407
« Reply #1 on: May 04, 2010, 09:38:03 PM »
Hi there,

Sorry to hear of your trouble -- are you playing the windows or OSX version of the game?  Also, if you are on windows can you look in the game install folder, under Tidalis_Data, and post the output_log.txt file that is there?  It sounds like something is a corrupted on your copy, but I'm not sure if that's a problem with the installer (it seemed fine earlier), or if it's a problem with something on your system or the way it uninstalled, or what.

Sorry for the trouble, hopefully that output log will help us sort it out quickly, though.  Thanks for your support!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline sil

  • Newbie
  • *
  • Posts: 6
Re: Trouble with the Tidalis License Key in .407
« Reply #2 on: May 05, 2010, 08:17:29 AM »
I am playing on Windows 7 Pro. The content of output_log.txt:
Quote
Player: init engine
Direct3D:
    Version:  Direct3D 9.0c [nvd3dum.dll 8.16.11.8681]
    Renderer: NVIDIA GeForce 8600M GT
    Vendor:   NVIDIA
    VRAM:     256 MB
desktop: 1280x800 63Hz; virtual: 1280x800 at 0,0
                 NullReferenceException: Object reference not set to an instance of an object
GameSettings.SaveToDisk ()
LicenseKeyMenu.ProcessClick_Unlock ()
ArcenButton.Render (Rect ParentBounds, Vector3 MousePositionFromTopLeft)
AbstractArcenWindow.WindowFunctionCall (Int32 WindowID)
UnityEngine.GUI+_Window.Do ()
UnityEngine.GUI.BeginWindows (UnityEngine.Event e, Int32 skinMode, UnityEngine.IDList idlist, Int32 editorWindowInstanceID)
 
(Filename:  Line: -1)

NullReferenceException: Object reference not set to an instance of an object
GameSettings.SaveToDisk ()
LicenseKeyMenu.ProcessClick_Unlock ()
ArcenButton.Render (Rect ParentBounds, Vector3 MousePositionFromTopLeft)
AbstractArcenWindow.WindowFunctionCall (Int32 WindowID)
UnityEngine.GUI+_Window.Do ()
UnityEngine.GUI.BeginWindows (UnityEngine.Event e, Int32 skinMode, UnityEngine.IDList idlist, Int32 editorWindowInstanceID)
 
(Filename:  Line: -1)

NullReferenceException: Object reference not set to an instance of an object
GameSettings.SaveToDisk ()
LicenseKeyMenu.ProcessClick_Unlock ()
ArcenButton.Render (Rect ParentBounds, Vector3 MousePositionFromTopLeft)
AbstractArcenWindow.WindowFunctionCall (Int32 WindowID)
UnityEngine.GUI+_Window.Do ()
UnityEngine.GUI.BeginWindows (UnityEngine.Event e, Int32 skinMode, UnityEngine.IDList idlist, Int32 editorWindowInstanceID)
 
(Filename:  Line: -1)

Cleanup player


To clarify: the game worked as version .40. I then uninstalled it with the uninstaller in the Tidalis folder and then reinstalled using the .407 installer. Thanks for the help.

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,226
Re: Trouble with the Tidalis License Key in .407
« Reply #3 on: May 05, 2010, 08:54:07 AM »
Okay, sorry about that, that was definitely a bug -- your output_log.txt was just what was needed, though.  I have just pushed out an 0.408 update, which you can download through the game and everything should be good after that.  I'm also going to push 0.408 installers, but those will take a few more hours for me to upload, and you don't need them anyway, since this bug didn't seem to impact updating (just trying to play the game or unlock it or edit settings, groan).

The issue here was some new "statistics tracking" code that was causing a nullreferenceexpection when settings.dat was to be saved, but I've put in the appropriate null checks now and it should be all good now.  I thought we'd caught all such issues with 0.407, but clearly we missed one.  :-[

Thanks for your patience, and for your support of our game!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline sil

  • Newbie
  • *
  • Posts: 6
Re: Trouble with the Tidalis License Key in .407
« Reply #4 on: May 05, 2010, 09:37:41 AM »
Everything works now. Thanks for working it out :)

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,226
Re: Trouble with the Tidalis License Key in .407
« Reply #5 on: May 05, 2010, 09:44:23 AM »
Awesome.  Thanks for your help!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!