Author Topic: Firing not working!?  (Read 974 times)

Offline Hedrik

  • Newbie
  • *
  • Posts: 5
Firing not working!?
« on: January 07, 2018, 09:50:24 AM »
Got from Humble - had to set execute bit on the binary file (StarwardRogue.app/Contents/MacOS/StarwardRogue) to get it to even run - unfortunately now, though I can get in the game and move around, I can not fire the main weapon!  Left-click does not work, and when I add a key binding in the options that also fails to fire...  The left-click does register properly for menus and to set the binding in options - any ideas on how to troubleshoot or fix this?  Obviously the game is not playable in this state.

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,158
Re: Firing not working!?
« Reply #1 on: January 07, 2018, 01:03:51 PM »
Hmm, very sorry to hear of the troubles you are having.  If I had to guess, I would usually say that it's a gamepad or similar that is causing the issues.  The fact that you can click in menus is awfully suspicious, though.  Are there any error messages in the RuntimeData folder inside the game folder?

On a related note, the fact that you had to set the execute bit is very surprising, as well.  The zip we provided to Humble had that set, I'm pretty positive.  I did it myself.  I'm not sure why it didn't unzip with that set for you. :/
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Hedrik

  • Newbie
  • *
  • Posts: 5
Re: Firing not working!?
« Reply #2 on: January 07, 2018, 04:49:43 PM »
I also thought it was odd that clicking worked in menus.

The only log file I can find is "ArcenDebugLog.txt" and it shows no errors, just startup/initialization entries.

I show this in "inputbindings.dat:"
Code: [Select]
KeyBindingV3:FireMainGun|LeftCommand|None|None|None|Mouse0|Noneand note that usingh the left command key also fails to fire the main weapon...

Just FYI, I used 7-zip to unzip the download...

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,158
Re: Firing not working!?
« Reply #3 on: January 07, 2018, 06:32:01 PM »
Hmm, 7zip should be fine. I think maybe it is set to having a modifier of command+click for some reason. That should be the modifier part. Changing that to None might fix it.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Hedrik

  • Newbie
  • *
  • Posts: 5
Re: Firing not working!?
« Reply #4 on: January 07, 2018, 07:33:14 PM »
Oh, it was none to start with - I changed it to command to see if using the keyboard would trigger the weapon...

Offline Draco18s

  • Resident Velociraptor
  • Core Member Mark V
  • *****
  • Posts: 4,072
Re: Firing not working!?
« Reply #5 on: January 07, 2018, 11:08:53 PM »
Are you in the tutorial? Likely so, in which case you don't HAVE a weapon yet.

Offline Hedrik

  • Newbie
  • *
  • Posts: 5
Re: Firing not working!?
« Reply #6 on: January 08, 2018, 12:47:41 AM »
Well, yes, but I am at the point where it is telling me to use my weapon - and there is a block that I cannot move thru...

Offline Hedrik

  • Newbie
  • *
  • Posts: 5
Re: Firing not working!?
« Reply #7 on: January 08, 2018, 12:50:03 AM »
Hahahaha!  I see now - I had to pick up the weapon!  LOL

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,158
Re: Firing not working!?
« Reply #8 on: January 08, 2018, 08:24:15 AM »
OH!  Thank goodness, I was about going nuts trying to figure this one out.  I'm glad that's all it was.  Thanks for the awesome call on this, Draco. :)
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Draco18s

  • Resident Velociraptor
  • Core Member Mark V
  • *****
  • Posts: 4,072
Re: Firing not working!?
« Reply #9 on: January 08, 2018, 01:50:25 PM »
Sometimes it's the simple stuff. :)

The "press E to equip" isn't super obvious (nothing in the voice over tells you to do that), but makes sense later, as you wouldn't want to automatically swap weapons every time you walk over one on the ground.

Glad to help!