Arcen Games

Games => AI War II => Private Alpha Discussion => Topic started by: x4000 on March 02, 2017, 03:41:44 PM

Title: Bleeding Edge Graphics Test Results?
Post by: x4000 on March 02, 2017, 03:41:44 PM
Heya!

What are your results from this?  https://wiki.arcengames.com/index.php?title=AI_War_2:Earlier_Than_Early_Alpha#Bleeding_Edge_Graphics_Test_.28Linux_In_Particular_Please_Try.21.29
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Gwmngilfen on March 02, 2017, 03:54:00 PM
Had a look in the BleedingEdgeTest directory, but I only see Unity56Test.exe which I assume is not a Linux binary. Is the Linux binary missing, or do I need to call it from an interpreter of some kind?

Hopefully it'll run once I know how - I have the Talos Principle running with Vulkan on this machine :)
Title: Re: Bleeding Edge Graphics Test Results?
Post by: orzelek on March 02, 2017, 03:58:52 PM
It crashed for me on windows after getting Vulkan initialized.
Attached crash report - I'm running Win 10 on i7-4790K and RX 480 with latest drivers.

Logs seem full of shader errors.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: x4000 on March 02, 2017, 04:28:32 PM
Had a look in the BleedingEdgeTest directory, but I only see Unity56Test.exe which I assume is not a Linux binary. Is the Linux binary missing, or do I need to call it from an interpreter of some kind?

Hopefully it'll run once I know how - I have the Talos Principle running with Vulkan on this machine :)

Oh sweet with the Talos Principle!

I just did a new build that is the same version, but now includes all the proper files.  Simply exiting and restarting steam should get you what you need.  Thanks for the catch!
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Lord Of Nothing on March 02, 2017, 04:28:56 PM
Ran fine for me, but this computer is less than three months old, so I'd hope so! :)
(Win10, i5-6600, GTX 1060 6GB)
Title: Re: Bleeding Edge Graphics Test Results?
Post by: x4000 on March 02, 2017, 04:36:39 PM
It crashed for me on windows after getting Vulkan initialized.
Attached crash report - I'm running Win 10 on i7-4790K and RX 480 with latest drivers.

Logs seem full of shader errors.

So... okay, wow, that's about as new and nice as they come when it's the AMD cards, eh?  Can you try running that with the command line arguments from here:

-force-glcoreXY: XY can be 32, 33, 40, 41, 42, 43, 44 or 45; each number representing a specific version of OpenGL. If the platform doesn’t support a specific version of OpenGL, Unity will fallback to a supported version.

You could basically open up a command prompt (Windows+R, type cmd), then drag and drop the executable in there.  Then type space and probably -force-glcore33 or similar.  Does it then run?

The fact that it crashes rather than switching over to DX or openGL is certainly concerning.

Anyhow, it thinks that your GPU has pretty much no capabilities based on what it is finding, which is bizarre.  It freaks out in there about even basic vertex shaders, so clearly it's just in a very invalid state for some reason.  I'm guessing drivers, but that's distressing to be sure.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: x4000 on March 02, 2017, 04:37:22 PM
Ran fine for me, but this computer is less than three months old, so I'd hope so! :)
(Win10, i5-6600, GTX 1060 6GB)

Sweet -- thanks. :)  Yep, the nVidia 900 and 1000 series should be the safest bets around, on any OS.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: rkfg on March 02, 2017, 04:48:19 PM
I have this after launching ./Unity56TestLinux.x86_64:
(http://i.imgur.com/5aqTVSC.jpg)
I don't know what it should look like, maybe it's glitched in some way compared to Windows. Talos Principle and Doom with Vulkan renderer (on Wine) work just fine.

My config: 64bit Debian Stretch/testing, i7-2600, 32 Gb RAM, 1070 GTX (proprietary driver v378.13), Awesome WM.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Gwmngilfen on March 02, 2017, 04:53:40 PM
I have the same results, flappy blue things under a bridge :)

Specs:
ArchLinux 4.9.12-1-ck #1 SMP PREEMPT Thu Feb 23 15:44:03 EST 2017 x86_64 GNU/Linux
vulkan-icd-loader 1.0.39.0-1
nvidia-ck 1:378.13-2 (ck-generic)
NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz
Mem:          15950
Title: Re: Bleeding Edge Graphics Test Results?
Post by: orzelek on March 02, 2017, 04:58:34 PM
With GLCore forced to 4.5 it runs - sad that vulkan is not starting up would be useful :)
Title: Re: Bleeding Edge Graphics Test Results?
Post by: x4000 on March 02, 2017, 05:02:28 PM
I have this after launching ./Unity56TestLinux.x86_64:
(http://i.imgur.com/5aqTVSC.jpg)
I don't know what it should look like, maybe it's glitched in some way compared to Windows. Talos Principle and Doom with Vulkan renderer (on Wine) work just fine.

My config: 64bit Debian Stretch/testing, i7-2600, 32 Gb RAM, 1070 GTX (proprietary driver v378.13), Awesome WM.

Yep, that's correct in terms of what you should see.  It's just a random scene.  Thank you!
Title: Re: Bleeding Edge Graphics Test Results?
Post by: x4000 on March 02, 2017, 05:04:45 PM
NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz
Mem:          15950

It was running the game "a little rough" under those specs?  Yikes!  I'm glad it was running, but I don't like the sound of that.  Vulkan might be a help on your machine, once we can get that to the main game, though.

With GLCore forced to 4.5 it runs - sad that vulkan is not starting up would be useful :)

Well, that's good that it runs at least with 4.5.  Bummer on the vulkan support, though.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Oralordos on March 02, 2017, 05:12:56 PM
I'm running on a surfacebook. When running with the keyboard (like I should be doing while playing a game) it runs fine. When I run it in tablet mode without the graphics card in the keyboard, it crashes on start. So... expected results.

Intel i7-6600U CPU 2.6 GHz 4 core
Nvidia GTX 965M
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Gwmngilfen on March 02, 2017, 05:34:59 PM
It was running the game "a little rough" under those specs?  Yikes!  I'm glad it was running, but I don't like the sound of that.  Vulkan might be a help on your machine, once we can get that to the main game, though.

Nope, it was fine. You may be confusing this thread with the i915 thread :)
Title: Re: Bleeding Edge Graphics Test Results?
Post by: RabidSanity on March 02, 2017, 06:30:57 PM
Worked fine on my machine.

System Specs:
 OS: Ubuntu 16.04.2 64bit
 GPU: Nvidia 770
 CPU: I7 6700
 Ram: 16 GB DDR4
Title: Re: Bleeding Edge Graphics Test Results?
Post by: daktaklakpak on March 02, 2017, 06:39:49 PM
Instant crash for me.  Attaching the crash log folder.

System specs:
OS: Windows 7 pro, sp1
GPU: Radeon R9 290X
Driver: 16.7.2 (older driver - ReLive series has had issues with my setup, so I've been staying away until it's stable)
CPU: i7-4790K @ 4.0 Ghz
Ram:  16 GB

More data from the GPU info panel, in case it might help:
Direct3D® Version
9.14.10.1197
OpenGL® Version
6.14.10.13441
OpenCL™ Version
2.0.6.0
AMD Mantle Version
9.1.10.123
AMD Mantle API Version
98309
Vulkan Driver Version
1.2.0
Vulkan API Version
1.0.17
Title: Re: Bleeding Edge Graphics Test Results?
Post by: BadgerBadger on March 02, 2017, 06:50:10 PM
Works perfectly; I see a couple creepy looking butterflies flying, some orange things too, and a bridge.

Fedora 25
Mesa 13.0.4
GPU Radeon R7 260X/360, open source drivers
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Tridus on March 02, 2017, 06:56:50 PM
Worked on my desktop, which is an old i7 860 and GeForce GTX 680, on Win10 x64.

Also worked on my Surface Book, both docked and undocked. I have the one with the dGPU, so that's using an nVidia GPU when docked, and an Intel one when in undocked tablet mode. There was a noticeable performance difference between them.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: lagomorph129 on March 02, 2017, 07:04:25 PM
Everybody seems to have fancy graphics cards D:
Am I not a true gamer? :(

Win 10
12GB RAM DDR3
Intel i7-4710 2.5 GHz (quad)

AI War 2 runs fine until I get north of 2k ships, (I admit that might be a bit low, but I have another pc I borrowed for testing which is much more like the upgrade I'll soon be getting) but I get no actual fps lag: just sim speed drop.

As for the Bleeding Edge Graphics, it seemed to run absolutely fine on my pc.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: CodeMichael on March 02, 2017, 08:19:46 PM
Running fine on Archlinux
i7-4770k @4.5ghz
1080gtx
Title: Re: Bleeding Edge Graphics Test Results?
Post by: donblas on March 02, 2017, 09:30:40 PM
I crashed. Here's a zip of the output:

https://www.dropbox.com/s/ncklkjnhf6b8k5w/2017-03-02_202538.zip?dl=0

Let me know if you need additional info. I'm a programmer by trade, and have Visual Studio and the like on this box.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: mooncows on March 02, 2017, 10:41:35 PM
OS: Windows 10
GPU: Geforce gtx 970
CPU: AMD FX-8350

No issues on launch at all.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Thalone on March 02, 2017, 11:18:29 PM
Computer 1:

Computer 2:

Title: Re: Bleeding Edge Graphics Test Results?
Post by: Lakshata on March 03, 2017, 12:07:42 AM
Ran Fine for me.

Operating System: Windows 10 Pro 64-bit (10.0, Build 14393) (14393.rs1_release.161220-1747)
Processor: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz (4 CPUs), ~3.3GHz
Memory: 8192MB RAM
Card name: NVIDIA GeForce GTX 960
Driver Version: 21.21.13.7866
Title: Re: Bleeding Edge Graphics Test Results?
Post by: gavin144 on March 03, 2017, 05:52:08 AM
Unity56TestLinux.x86 works fine for me on my desktop, but Unity56TestLinux.x86_64 crashes:
Code: [Select]
Set current directory to /steam/SteamApps/common/AI War 2/BleedingEdgeTest
Found path: /steam/SteamApps/common/AI War 2/BleedingEdgeTest/Unity56TestLinux.x86_64
Mono path[0] = '/steam/SteamApps/common/AI War 2/BleedingEdgeTest/Unity56TestLinux_Data/Managed'
Mono path[1] = '/steam/SteamApps/common/AI War 2/BleedingEdgeTest/Unity56TestLinux_Data/Mono'
Mono config path = '/steam/SteamApps/common/AI War 2/BleedingEdgeTest/Unity56TestLinux_Data/Mono/etc'
Preloaded 'ScreenSelector.so'
Player data archive not found at `/steam/SteamApps/common/AI War 2/BleedingEdgeTest/Unity56TestLinux_Data/data.unity3d`, using local filesystemAborted (core dumped)

Adding -force-glcoreXY: with XY of any of 32, 33, 40, 41, 42, 43, 44 or 45 makes it work.

OS: Arch Linux
Kernel: x86_64 Linux 4.8.13-1-ARCH
CPU: Intel Core i7-3820 CPU @ 3.6GHz
GPU: Gallium 0.4 on AMD TAHITI (DRM 2.46.0 / 4.8.13-1-ARCH, LLVM 3.9.1)
RAM: 15991MiB
Title: Re: Bleeding Edge Graphics Test Results?
Post by: jerith on March 03, 2017, 10:59:07 AM
Works fine for me. MacBook Pro (13-inch, Mid 2012) with as much extra RAM shoved into it as I could make fit. It claims to have Intel HD Graphics 4000 1024 MB for drawing things to the screen. This is the last pre-Retina model they released, I believe.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: BadgerBadger on March 03, 2017, 11:15:53 AM
It also worked on a 15'' 2012 macbook pro (pre-retina)
Title: Re: Bleeding Edge Graphics Test Results?
Post by: treyra on March 03, 2017, 11:38:46 PM
Worked fine (5 sec launch time) on a MSI laptop,

Windows 10
GTX 960m
i7 quad core
16 GB ram.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: mithrandi on March 04, 2017, 04:15:03 AM
Works for me.

OS: Debian Unstable
Graphics hardware: NVIDIA GeForce GTX 970
Driver version: 375.39
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Cyborg on March 04, 2017, 03:55:35 PM
Works for me, Windows 7 64 bit.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Toranth on March 04, 2017, 05:43:13 PM
Instant crash for me.  Attaching the crash log folder.

System specs:
OS: Windows 7 pro, sp1
GPU: Radeon R9 290X
Driver: 16.7.2 (older driver - ReLive series has had issues with my setup, so I've been staying away until it's stable)
CPU: i7-4790K @ 4.0 Ghz
Ram:  16 GB
This is pretty much my computer, and my result, too - crash on launch.  I have the latest AMD drivers, however.
Using the GL force command line option, all version work.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: Burnstreet on March 05, 2017, 03:26:59 PM
works fine for me on win10/i7/GF680M with latest geforce drivers
The game runs fine, too
Title: Re: Bleeding Edge Graphics Test Results?
Post by: NichG on March 31, 2017, 11:29:38 PM
On my Ubuntu 16.10 laptop the Unity56TestLinux.x86 executable gave me a window with no contents until I full-screened it, then it seemed to work. The second time I ran it worked directly (it remembered the fullscreen setting I guess). The Unity56TestLinux.x86_64 popped up a window briefly and then aborted without an informative error message (just 'Aborted'). Kind of surprising, since my OS/environment is 64bit, so its the reverse of what should have happened.

I'm running the 375.39 NVidia driver with a GTX 1080. I have something called vulkaninfo, but when I run that I get '/build/vulkan-ijAUlz/vulkan-1.0.21.0+dfsg1/demos/vulkaninfo.c:1415: failed with VK_ERROR_INITIALIZATION_FAILED' so I suspect there might be something wrong with my (64bit?) Vulkan driver?

Works fine under Wine by the way, even windowed.
Title: Re: Bleeding Edge Graphics Test Results?
Post by: EvilSPAM on April 01, 2017, 06:03:59 AM
Worked fine here.

OS: Arch Linux (x86_64, 4.10.6-1-ARCH)
CPU: i7-6700
RAM: 8GB
GPU: GTX 970 (Driver Version: 378.13)

Title: Re: Bleeding Edge Graphics Test Results?
Post by: x4000 on April 03, 2017, 10:18:16 AM
Thank you! :)