Author Topic: Can't stop firing spells  (Read 821 times)

Offline Nanako

  • Newbie
  • *
  • Posts: 2
Can't stop firing spells
« on: June 17, 2012, 05:54:26 AM »
hi everyone. i was poking around in the spell encyclopaedia earlier, and when i came out, my character has started firing her first spell (mouse1) nonstop.

if i swap spells around, she continually fires whatever i put into that slot. The problem persists if i make a new character, or even start a new world o.o saving and loading the same world makes it persist too, as does moving to new areas. Even if i switch all the control settings for the ability 1 slot, it's still happening.

i would guess this indicates a hardware problem, but what, i'm not sure. i'm seeing no strange behaviour in anything else, i've disabled my firewall, unplugged my gamepad. i'm not getting garbage text in a text editor, or any strange behaviour in mouse controlled games. it seems only this game is having the problem. so i'm thoroughly confused

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,236
Re: Can't stop firing spells
« Reply #1 on: June 18, 2012, 09:39:03 AM »
Almost always this is related to a gamepad -- you could just unbind the gamepad from the action 1 button and that might solve it regardless of what input your OS is getting from your gamepad.

Hope that helps!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline LaughingThesaurus

  • Master Member Mark II
  • *****
  • Posts: 1,723
Re: Can't stop firing spells
« Reply #2 on: June 19, 2012, 07:32:33 PM »
I actually had an issue similar to this with air shield, which I think was in slot 8. I had to leave to the world map, then go back into the chunk, in order to stop constantly casting it. Even then, the effect kept flicking between on and off, but harmlessly because I was unaffected by cooldowns or mana cost. When I left and came back in again, it was gone. I'm not sure what happened, but maybe that's a solution.
I didn't have anything plugged in gamepad-wise either, though... and the spell kept recasting itself no matter what slot it was in, so maybe it was a totally different issue.