Author Topic: [RESOLVED] Latest comes up with black screen except menu GUI  (Read 5865 times)

Offline syndicatedragon

  • Jr. Member
  • **
  • Posts: 50
[RESOLVED] Latest comes up with black screen except menu GUI
« on: April 21, 2012, 01:43:38 PM »
The previous version I tried (the one where the GPU load slider was added I think?) worked fine. The version I upgraded to this morning gives me a totally black screen except for the menus. I tried launching it both from Steam (which is where I got these screenshots) and straight from the command line. I wanted to see if anyone here had seen this before I open a ticket. Also, what information would be helpful for debugging this?

http://cloud.steampowered.com/ugc/560939541720794597/C02D909220B78775453B296716B3E33DC92224F1/

http://cloud.steampowered.com/ugc/560939541720801602/23D95987EC2C2ECB83C7C4995BE65359BDBD3B6F/
« Last Edit: April 22, 2012, 07:18:43 PM by x4000 »

Offline tigersfan

  • Arcen Games Contractor
  • Arcen Staff
  • Master Member Mark II
  • *****
  • Posts: 1,599
Re: Latest comes up with black screen except menu GUI
« Reply #1 on: April 21, 2012, 01:47:09 PM »
Do you have any logs in your "Runtime data" folder? Also, does anything happen if you actually try going into a game?

To be totally honest, since I've not yet heard any reports like this at all, I'm thinking it's possible that your install got corrupted somehow. You may need to try re-installing the game.

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,231
Re: Latest comes up with black screen except menu GUI
« Reply #2 on: April 21, 2012, 01:49:01 PM »
There's also a handy new 1.0 installer on the site -- no updates needed!
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline syndicatedragon

  • Jr. Member
  • **
  • Posts: 50
Re: Latest comes up with black screen except menu GUI
« Reply #3 on: April 21, 2012, 03:51:09 PM »
Do you have any logs in your "Runtime data" folder? Also, does anything happen if you actually try going into a game?

To be totally honest, since I've not yet heard any reports like this at all, I'm thinking it's possible that your install got corrupted somehow. You may need to try re-installing the game.
The second screen shot was from "in-game".

I uninstalled and tried the 1.0 installer. It seems to work fine so I guess something must have gone awry when updating.

However, when I ran the game directly from the installer, the dialog box at startup prompting for a key did not have text labels on the buttons below. When I quit and re-ran the game, they looked fine.

Offline Colonel J

  • Newbie Mark III
  • *
  • Posts: 36
Re: Latest comes up with black screen except menu GUI
« Reply #4 on: April 22, 2012, 12:00:01 PM »
Hi, thought you should know I had exactly the same problem with my update to 1.0, totally black screen except for menus. I purchased and downloaded from Gamersgate today and applied the latest update from the game menu.

As suggested I uninstalled and re-installed with the 1.0 version from the Arcen site and all is now OK.  I guess it's not an issue after Monday though if the new 1.0 is going up on Gamersgate?

No issues during either install process other than Avast Free AV's new AutoSandbox setting terminating both the install and the uninstall in the first 20 seconds as it thinks your installer .exe has 'low prevalence/reputation is low'. until I turned it off completely in the AV settings.  I mention it just in case, but I'm doubting that was anything to do with it though, as it did that again on my first go at the fresh 1.0 install file from Arcen until I turned AutoSandbox off again. but the game looked fine afterward. This is a new thing in Avast 2012 that I've not seen being set off before. As I say, may just be an AV quirk and nothing to do with it....

Offline Smiling Spectre

  • Newbie Mark II
  • *
  • Posts: 17
Re: Latest comes up with black screen except menu GUI
« Reply #5 on: April 22, 2012, 04:23:44 PM »
The same for me. I had v.931, and when I tried to run it today, it said "1 official update found". I was slightly surprised, as I seen about 6 updates on blog, but, well, game knows better, yes?

No. :) After installing it, it seems, game missed everything. Log is 85 kb, and full of "missing file" notices like this:
Quote
4/23/2012 12:21:28 AM
File Images/Achievements/KillOverlord_1_On does not exist!

   at System.Environment.get_StackTrace()
   at ArcenDebugging.ArcenDebugLog(System.String Message)
   at ArcenDebugging.TellTheDeveloper(System.String Message)
   at GameImage.StartLoading()
   at Game.UpdateStreaming()
   at MainCameraLogic.MainUpdateLogic()
   at MainCameraLogic.Update()
or this
Quote
4/23/2012 12:21:31 AM
File Images/Achievements/GetLegendaryEnchant_ManaCostReducingEnchant_On does not exist!

   at System.Environment.get_StackTrace()
   at ArcenDebugging.ArcenDebugLog(System.String Message)
   at ArcenDebugging.TellTheDeveloper(System.String Message)
   at GameImage.StartLoading()
   at Game.UpdateStreaming()
   at MainCameraLogic.MainUpdateLogic()
   at MainCameraLogic.Update()

or even this (there are about 6 such messages, except miriad of "achievment" ones):
Quote
4/23/2012 12:21:33 AM
File Items/CatchupEnchantContainer does not exist!

   at System.Environment.get_StackTrace()
   at ArcenDebugging.ArcenDebugLog(System.String Message)
   at ArcenDebugging.TellTheDeveloper(System.String Message)
   at GameImage.StartLoading()
   at Game.UpdateStreaming()
   at MainCameraLogic.MainUpdateLogic()
   at MainCameraLogic.Update()

It seems for me that updater went mad and simply missed all updates between 0.931 and last one. :)

What do you recommend? Reinstall as 1.0?
« Last Edit: April 22, 2012, 04:27:10 PM by Smiling Spectre »

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,231
Re: Latest comes up with black screen except menu GUI
« Reply #6 on: April 22, 2012, 06:59:54 PM »
It's correct that there is only one update between 0.931 and 1.000 -- when updates are small, we roll them into one.  I recommend reinstalling with 1.0, but I'm going to look at what is up with the updater.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Arcen Staff
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,231
Re: [RESOLVED] Latest comes up with black screen except menu GUI
« Reply #7 on: April 22, 2012, 07:18:55 PM »
Sorry about this!

I've now fixed the updates for people who are upgrading from prior versions so that this should not happen again.  I set something wrong in the file, and it caused it to skip the intermediate updates; which meant that the 1.0 that you arrived at was missing key files and thus unable to run.  Normally our updates are supposed to download all the intermediate ones and then apply them all as one rollup, but it was just skipping right to the end because of how 1.0 was flagged in the update xml file.  Whoops! 

That's now resolved, but if you've updated to 1.0 via the updater prior to this from any version other than 0.971 (Release Candidate 2), then you're definitely going to want to do a fresh install from the 1.0 build here: http://www.arcengames.com/w/index.php/avww-downloads  You can just install that right over your existing copy of the game and it won't harm your savegames or settings files, and will get you all ship-shape.
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!