Author Topic: 2 Player MP Game grinds to a halt after 1st assault on one of the AI's homeworld  (Read 1690 times)

Offline Vhorthex

  • Newbie Mark II
  • *
  • Posts: 19
Hey there,

My friend and I just had an amazing game of about 13 hours... grind to a halt. Zooming in and out is unresponsive, attempting to access/close the galaxy map is barely functional. Even pausing the game is a feat.

The drop in FPS was so intense, that regardless of any settings we picked, got less than 'tick' per second. I was able to load the game in single player and let that time pass. But everytime the AI goes through a wormwhole and gets attacked by our turret array, the game again starts to drastically slow down. Something like 0.1 FPS.

Thing is, we aren't at a crazy 40k+ ships, we have have 3-4k each, and the AI has 15k. I'm a little confused as to why it's behaving like this.

System Spec:

E8400 @ 3.0ghz
GTX 260
4Gb Ram
Vista 64

My friend has the same setup except with a 8800GT. In any case i'm the host.

I read the tips from X4000 on how to increase MP speed, but since I'm encountering these problems even in single player, i think there could be something else I'm overlooking? I can provide save file for tests if anyone is so inclined! :)

Cheers,


Offline x4000

  • Chris Park, Arcen Games Founder and Lead Designer
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 31,226
Hmm, sorry to hear about your trouble there.  Can you check in your runtimedata folder in your game folder to see if any errors were logged?  If it's hitting something that is causing a ton of errors, that could cause your game speed to plummet.  If there aren't errors (or, actually, if there are), we'd need to take a look at the save to see what we can see on there.

Your E8400 is really extremely nice for the purposes of AI War, so there's no reason that you'd generally see performance like that.  So it could be spewing errors into log files, or it could be some sort of odd performance bottleneck, or you could be stressing it more than you realize with some specific matchups (how many ships you have overall in the game matters less than how many you put on a single planet, for instance -- and the CPU cost goes up multiplicatively, so if you have a 4000x4000 battle that is actually at least 16x more intensive than a 1000x1000 battle, not 4x more.  Usually that's not something one runs into, though -- especially not on Normal ship caps, which is what we recommend, but even on High it shouldn't be to the point of being a problem, usually.

My money would be on the error files, but I guess we'll see, in short. :)
Have ideas or bug reports for one of our games?  Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Mánagarmr

  • Core Member Mark V
  • *****
  • Posts: 4,272
  • if (isInRange(target)) { kill(target); }
Also, upload the save so other people can test the same scenario. Would help us a lot!
Click here to get started with Mantis for Suggestions and Bug Reports.

Thank you for contributing to making the game better!

Offline Vhorthex

  • Newbie Mark II
  • *
  • Posts: 19
Hi X4000! :)

Yes, I think you were correct about the errors.

Here is a sample from the error log. It's the same line that repeats many, many times.

11/13/2010 5:37:29 PM
-----------------------------------System.NullReferenceException: Object reference not set to an instance of an object
  at AITactics.ShipCombatTactics (Int32 PlayerNumber, Int32 AIAttackingThreateningAIUnits, Int32 HumanMilitaryUnits) [0x00000] in <filename unknown>:0
  at AILoop.RunAILoop () [0x00000] in <filename unknown>:0
11/13/2010 5:37:31 PM
-----------------------------------System.NullReferenceException: Object reference not set to an instance of an object
  at AITactics.ShipCombatTactics (Int32 PlayerNumber, Int32 AIAttackingThreateningAIUnits, Int32 HumanMilitaryUnits) [0x00000] in <filename unknown>:0
  at AILoop.RunAILoop () [0x00000] in <filename unknown>:0
11/13/2010 5:37:31 PM

Would this help in isolating the issue? I'm off to work in a few minutes so I don't have time to join a free file hosting service, so I can't post my save just yet. I will do so when I return from work.

Cheers,

Offline keith.lamothe

  • Arcen Games Staff
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 19,504
We fixed that one several versions ago, I believe.  What version are you playing?
Have ideas or bug reports for one of our games? Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Vhorthex

  • Newbie Mark II
  • *
  • Posts: 19
Hi Keith,

My version is currently 4.021 (The Game was downloaded through steam, if that has any impact).

I'll try to get my save file up on some free file sharing server, if that would help more.

Really appreciate the fact you guys are looking into this. :)

Cheers,

Offline keith.lamothe

  • Arcen Games Staff
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 19,504
Yea, that bug was fixed after 4.021; if you update to the latest beta it should go away :)
Have ideas or bug reports for one of our games? Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Vhorthex

  • Newbie Mark II
  • *
  • Posts: 19
Ouuuu, ok!

I was just under the impression that beta releases were solely about the upcoming expansions. I didn't want to revert to a trial version. I guess I just download the patches and disable the trial expansion? (Spires)

Wow, sorry for nausing you up with this then. :(

Still, best support ever! I'll give it a whirl next weekend and let you know how it went.

Thanks again!

Offline keith.lamothe

  • Arcen Games Staff
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 19,504
Yea, we only ever have one official version and one beta version, both apply to the base game and all expansions :)  If updating enables the Light Of The Spire expansion you can just disable it to avoid trial mode.
Have ideas or bug reports for one of our games? Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!

Offline Vhorthex

  • Newbie Mark II
  • *
  • Posts: 19
Haha!

YES!

There is still a little chug chug when the AI moves system but it's completely playable. Not even close to the massive drops I had before.

Thanks for helping out!

And thanks for an awesome game!

Cheers,
V.

Offline keith.lamothe

  • Arcen Games Staff
  • Administrator
  • Zenith Council Member Mark III
  • *****
  • Posts: 19,504
Our pleasure :)
Have ideas or bug reports for one of our games? Mantis for Suggestions and Bug Reports. Thanks for helping to make our games better!